p PatchFirst

CVE-2025-29927

CVE-2025-29927 · Authorization Bypass in Next.js Middleware

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Next.js is a React framework for building full-stack web applications. Starting in version 1.11.4 and prior to versions 12.3.5, 13.5.9, 14.2.25, and 15.2.3, it is possible to bypass authorization checks within a Next.js application, if the authorization check occurs in middleware. If patching to a safe version is infeasible, it is recommend that you prevent external user requests which contain the x-middleware-subrequest header from reaching your Next.js application. This vulnerability is fixed in 12.3.5, 13.5.9, 14.2.25, and 15.2.3.

CVSS 9.1 · Kritisch · EPSS 99,2% · Öffentlicher Exploit · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: node

Betroffene Produkte und Versionen

  • next.js

    Softwareversionen
    • >= 11.1.4, < 12.3.5: Betroffen
    • >= 14.0.0, < 14.2.25: Betroffen
    • >= 15.0.0, < 15.2.3: Betroffen
    • >= 13.0.0, < 13.5.9: Betroffen

    Keine Korrektur veröffentlicht

  • next npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 13.0.0, < 13.5.9

    Auf 13.5.9 aktualisieren

  • next npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 14.0.0, < 14.2.25

    Auf 14.2.25 aktualisieren

  • next npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 15.0.0, < 15.2.3

    Auf 15.2.3 aktualisieren

  • next npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 12.0.0, < 12.3.5

    Auf 12.3.5 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →