CVE-2025-29927
CVE-2025-29927 · Authorization Bypass in Next.js Middleware
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
Next.js is a React framework for building full-stack web applications. Starting in version 1.11.4 and prior to versions 12.3.5, 13.5.9, 14.2.25, and 15.2.3, it is possible to bypass authorization checks within a Next.js application, if the authorization check occurs in middleware. If patching to a safe version is infeasible, it is recommend that you prevent external user requests which contain the x-middleware-subrequest header from reaching your Next.js application. This vulnerability is fixed in 12.3.5, 13.5.9, 14.2.25, and 15.2.3.
CVSS 9.1 · Critique · EPSS 99,2% · Code d’exploitation public · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: node
Produits et versions concernés
next.js
- Versions du logiciel
- >= 11.1.4, < 12.3.5: Concernée
- >= 14.0.0, < 14.2.25: Concernée
- >= 15.0.0, < 15.2.3: Concernée
- >= 13.0.0, < 13.5.9: Concernée
Aucun correctif publié
next npm
- Plages de versions concernées
- SEMVER: ≥ 13.0.0, < 13.5.9
Mettez à jour vers 13.5.9
next npm
- Plages de versions concernées
- SEMVER: ≥ 14.0.0, < 14.2.25
Mettez à jour vers 14.2.25
next npm
- Plages de versions concernées
- SEMVER: ≥ 15.0.0, < 15.2.3
Mettez à jour vers 15.2.3
next npm
- Plages de versions concernées
- SEMVER: ≥ 12.0.0, < 12.3.5
Mettez à jour vers 12.3.5
Sources originales
- https://github.com/vercel/next.js/security/advisories/GHSA-f82v-jwr5-mffw
- https://github.com/vercel/next.js/commit/52a078da3884efe6501613c7834a3d02a91676d2
- https://github.com/vercel/next.js/commit/5fd3ae8f8542677c6294f32d18022731eab6fe48
- https://github.com/vercel/next.js/releases/tag/v12.3.5
- https://github.com/vercel/next.js/releases/tag/v13.5.9
- http://www.openwall.com/lists/oss-security/2025/03/23/3
- http://www.openwall.com/lists/oss-security/2025/03/23/4
- https://security.netapp.com/advisory/ntap-20250328-0002/
- https://nvd.nist.gov/vuln/detail/CVE-2025-29927