CVE-2025-30193
CVE-2025-30193 · Denial of service via crafted TCP exchange
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
In some circumstances, when DNSdist is configured to allow an unlimited number of queries on a single, incoming TCP connection from a client, an attacker can cause a denial of service by crafting a TCP exchange that triggers an exhaustion of the stack and a crash of DNSdist, causing a denial of service. The remedy is: upgrade to the patched 1.9.10 version. A workaround is to restrict the maximum number of queries on incoming TCP connections to a safe value, like 50, via the setMaxTCPQueriesPerConnection setting. We would like to thank Renaud Allard for bringing this issue to our attention.
CVSS 7.5 · Alta · EPSS 0,6% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system
Productos y versiones afectados
dnsdist
- Versiones
- 1.9.10: No afectada (semver)
Sin corrección publicada
dnsdist Debian:12
- Versiones
- 1.7.3-2
- 1.8.0-1
- 1.8.1-1
- 1.8.2-1
- 1.8.2-2
- 1.8.2-3
- 1.8.3-1
- 1.8.3-2
- 1.8.3-3
- 1.9.10-1
- 1.9.3-1
- 1.9.4-1
- 1.9.5-1
- 1.9.6-1
- 1.9.8-1
- 1.9.9-1
- 2.0.0-1
- 2.0.0-2
- 2.0.0-3
- 2.0.0-4
- 2.0.0-5
- 2.0.0-6
- 2.0.0~rc1-1
- 2.0.0~rc1-2
- 2.0.0~rc2-1
- 2.0.1-1
- 2.0.2-1
- 2.0.3-1
- 2.0.4-1
- 2.0.5-1
- 2.0.5-2
- 2.0.5-3
- 2.0.6-1
- 2.1.0-1
- 2.1.0-2
- 2.1.1-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
dnsdist Debian:13
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.9.10-1
Actualiza a 1.9.10-1
dnsdist Debian:14
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.9.10-1
Actualiza a 1.9.10-1
dnsdist Ubuntu:Pro:22.04:LTS
- Versiones
- 1.5.1-3build2
- 1.6.1-1build1
- 1.6.1-1ubuntu0.1~esm1
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.6.1-1ubuntu0.1~esm2
Actualiza a 1.6.1-1ubuntu0.1~esm2
dnsdist Ubuntu:Pro:24.04:LTS
- Versiones
- 1.8.0-1
- 1.8.2-1
- 1.8.2-2
- 1.8.2-3
- 1.8.3-1
- 1.8.3-2
- 1.8.3-2build1
- 1.8.3-2build2
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.8.3-2ubuntu0.1~esm1
Actualiza a 1.8.3-2ubuntu0.1~esm1