p PatchFirst

CVE-2025-30193

CVE-2025-30193 · Denial of service via crafted TCP exchange

This page contains facts from public vulnerability sources. Check the original advisory before updating.

In some circumstances, when DNSdist is configured to allow an unlimited number of queries on a single, incoming TCP connection from a client, an attacker can cause a denial of service by crafting a TCP exchange that triggers an exhaustion of the stack and a crash of DNSdist, causing a denial of service. The remedy is: upgrade to the patched 1.9.10 version. A workaround is to restrict the maximum number of queries on incoming TCP connections to a safe value, like 50, via the setMaxTCPQueriesPerConnection setting. We would like to thank Renaud Allard for bringing this issue to our attention.

CVSS 7.5 · High · EPSS 0.6% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • dnsdist

    Versions
    • 1.9.10: Not affected (semver)

    No fix published

  • dnsdist Debian:12

    Versions
    • 1.7.3-2
    • 1.8.0-1
    • 1.8.1-1
    • 1.8.2-1
    • 1.8.2-2
    • 1.8.2-3
    • 1.8.3-1
    • 1.8.3-2
    • 1.8.3-3
    • 1.9.10-1
    • 1.9.3-1
    • 1.9.4-1
    • 1.9.5-1
    • 1.9.6-1
    • 1.9.8-1
    • 1.9.9-1
    • 2.0.0-1
    • 2.0.0-2
    • 2.0.0-3
    • 2.0.0-4
    • 2.0.0-5
    • 2.0.0-6
    • 2.0.0~rc1-1
    • 2.0.0~rc1-2
    • 2.0.0~rc2-1
    • 2.0.1-1
    • 2.0.2-1
    • 2.0.3-1
    • 2.0.4-1
    • 2.0.5-1
    • 2.0.5-2
    • 2.0.5-3
    • 2.0.6-1
    • 2.1.0-1
    • 2.1.0-2
    • 2.1.1-1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • dnsdist Debian:13

    Affected ranges
    • ECOSYSTEM: < 1.9.10-1

    Update to 1.9.10-1

  • dnsdist Debian:14

    Affected ranges
    • ECOSYSTEM: < 1.9.10-1

    Update to 1.9.10-1

  • dnsdist Ubuntu:Pro:22.04:LTS

    Versions
    • 1.5.1-3build2
    • 1.6.1-1build1
    • 1.6.1-1ubuntu0.1~esm1
    Affected ranges
    • ECOSYSTEM: < 1.6.1-1ubuntu0.1~esm2

    Update to 1.6.1-1ubuntu0.1~esm2

  • dnsdist Ubuntu:Pro:24.04:LTS

    Versions
    • 1.8.0-1
    • 1.8.2-1
    • 1.8.2-2
    • 1.8.2-3
    • 1.8.3-1
    • 1.8.3-2
    • 1.8.3-2build1
    • 1.8.3-2build2
    Affected ranges
    • ECOSYSTEM: < 1.8.3-2ubuntu0.1~esm1

    Update to 1.8.3-2ubuntu0.1~esm1

Original sources

Check your server →