CVE-2025-30193
CVE-2025-30193 · Denial of service via crafted TCP exchange
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
In some circumstances, when DNSdist is configured to allow an unlimited number of queries on a single, incoming TCP connection from a client, an attacker can cause a denial of service by crafting a TCP exchange that triggers an exhaustion of the stack and a crash of DNSdist, causing a denial of service. The remedy is: upgrade to the patched 1.9.10 version. A workaround is to restrict the maximum number of queries on incoming TCP connections to a safe value, like 50, via the setMaxTCPQueriesPerConnection setting. We would like to thank Renaud Allard for bringing this issue to our attention.
CVSS 7.5 · Hoch · EPSS 0,6% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system
Betroffene Produkte und Versionen
dnsdist
- Softwareversionen
- 1.9.10: Nicht betroffen (semver)
Keine Korrektur veröffentlicht
dnsdist Debian:12
- Softwareversionen
- 1.7.3-2
- 1.8.0-1
- 1.8.1-1
- 1.8.2-1
- 1.8.2-2
- 1.8.2-3
- 1.8.3-1
- 1.8.3-2
- 1.8.3-3
- 1.9.10-1
- 1.9.3-1
- 1.9.4-1
- 1.9.5-1
- 1.9.6-1
- 1.9.8-1
- 1.9.9-1
- 2.0.0-1
- 2.0.0-2
- 2.0.0-3
- 2.0.0-4
- 2.0.0-5
- 2.0.0-6
- 2.0.0~rc1-1
- 2.0.0~rc1-2
- 2.0.0~rc2-1
- 2.0.1-1
- 2.0.2-1
- 2.0.3-1
- 2.0.4-1
- 2.0.5-1
- 2.0.5-2
- 2.0.5-3
- 2.0.6-1
- 2.1.0-1
- 2.1.0-2
- 2.1.1-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
dnsdist Debian:13
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.9.10-1
Auf 1.9.10-1 aktualisieren
dnsdist Debian:14
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.9.10-1
Auf 1.9.10-1 aktualisieren
dnsdist Ubuntu:Pro:22.04:LTS
- Softwareversionen
- 1.5.1-3build2
- 1.6.1-1build1
- 1.6.1-1ubuntu0.1~esm1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.6.1-1ubuntu0.1~esm2
Auf 1.6.1-1ubuntu0.1~esm2 aktualisieren
dnsdist Ubuntu:Pro:24.04:LTS
- Softwareversionen
- 1.8.0-1
- 1.8.2-1
- 1.8.2-2
- 1.8.2-3
- 1.8.3-1
- 1.8.3-2
- 1.8.3-2build1
- 1.8.3-2build2
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.8.3-2ubuntu0.1~esm1
Auf 1.8.3-2ubuntu0.1~esm1 aktualisieren