CVE-2025-30218
CVE-2025-30218 · Next.js may leak x-middleware-subrequest-id to external hosts
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
Next.js is a React framework for building full-stack web applications. To mitigate CVE-2025-29927, Next.js validated the x-middleware-subrequest-id which persisted across multiple incoming requests. However, this subrequest ID is sent to all requests, even if the destination is not the same host as the Next.js application. Initiating a fetch request to a third-party within Middleware will send the x-middleware-subrequest-id to that third party. This vulnerability is fixed in 12.3.6, 13.5.10, 14.2.26, and 15.2.4.
CVSS 1.7 · Baja · EPSS 0,4% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: node
Productos y versiones afectados
next.js
- Versiones
- = 12.3.5: Afectada
- = 13.5.9: Afectada
- = 14.2.25: Afectada
- = 15.2.3: Afectada
Sin corrección publicada
next npm
- Versiones
- 12.3.5
- Intervalos de versiones afectados
- SEMVER: ≥ 12.3.5, < 12.3.6
Actualiza a 12.3.6
next npm
- Versiones
- 13.5.9
- Intervalos de versiones afectados
- SEMVER: ≥ 13.5.9, < 13.5.10
Actualiza a 13.5.10
next npm
- Versiones
- 14.2.25
- Intervalos de versiones afectados
- SEMVER: ≥ 14.2.25, < 14.2.26
Actualiza a 14.2.26
next npm
- Versiones
- 15.2.3
- Intervalos de versiones afectados
- SEMVER: ≥ 15.2.3, < 15.2.4
Actualiza a 15.2.4