CVE-2025-30218
CVE-2025-30218 · Next.js may leak x-middleware-subrequest-id to external hosts
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
Next.js is a React framework for building full-stack web applications. To mitigate CVE-2025-29927, Next.js validated the x-middleware-subrequest-id which persisted across multiple incoming requests. However, this subrequest ID is sent to all requests, even if the destination is not the same host as the Next.js application. Initiating a fetch request to a third-party within Middleware will send the x-middleware-subrequest-id to that third party. This vulnerability is fixed in 12.3.6, 13.5.10, 14.2.26, and 15.2.4.
CVSS 1.7 · Faible · EPSS 0,4% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: node
Produits et versions concernés
next.js
- Versions du logiciel
- = 12.3.5: Concernée
- = 13.5.9: Concernée
- = 14.2.25: Concernée
- = 15.2.3: Concernée
Aucun correctif publié
next npm
- Versions du logiciel
- 12.3.5
- Plages de versions concernées
- SEMVER: ≥ 12.3.5, < 12.3.6
Mettez à jour vers 12.3.6
next npm
- Versions du logiciel
- 13.5.9
- Plages de versions concernées
- SEMVER: ≥ 13.5.9, < 13.5.10
Mettez à jour vers 13.5.10
next npm
- Versions du logiciel
- 14.2.25
- Plages de versions concernées
- SEMVER: ≥ 14.2.25, < 14.2.26
Mettez à jour vers 14.2.26
next npm
- Versions du logiciel
- 15.2.3
- Plages de versions concernées
- SEMVER: ≥ 15.2.3, < 15.2.4
Mettez à jour vers 15.2.4