p PatchFirst

CVE-2025-30218

CVE-2025-30218 · Next.js may leak x-middleware-subrequest-id to external hosts

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Next.js is a React framework for building full-stack web applications. To mitigate CVE-2025-29927, Next.js validated the x-middleware-subrequest-id which persisted across multiple incoming requests. However, this subrequest ID is sent to all requests, even if the destination is not the same host as the Next.js application. Initiating a fetch request to a third-party within Middleware will send the x-middleware-subrequest-id to that third party. This vulnerability is fixed in 12.3.6, 13.5.10, 14.2.26, and 15.2.4.

CVSS 1.7 · Niedrig · EPSS 0,4% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: node

Betroffene Produkte und Versionen

  • next.js

    Softwareversionen
    • = 12.3.5: Betroffen
    • = 13.5.9: Betroffen
    • = 14.2.25: Betroffen
    • = 15.2.3: Betroffen

    Keine Korrektur veröffentlicht

  • next npm

    Softwareversionen
    • 12.3.5
    Betroffene Versionsbereiche
    • SEMVER: ≥ 12.3.5, < 12.3.6

    Auf 12.3.6 aktualisieren

  • next npm

    Softwareversionen
    • 13.5.9
    Betroffene Versionsbereiche
    • SEMVER: ≥ 13.5.9, < 13.5.10

    Auf 13.5.10 aktualisieren

  • next npm

    Softwareversionen
    • 14.2.25
    Betroffene Versionsbereiche
    • SEMVER: ≥ 14.2.25, < 14.2.26

    Auf 14.2.26 aktualisieren

  • next npm

    Softwareversionen
    • 15.2.3
    Betroffene Versionsbereiche
    • SEMVER: ≥ 15.2.3, < 15.2.4

    Auf 15.2.4 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →