p PatchFirst

CVE-2025-48068

CVE-2025-48068 · Information exposure in Next.js dev server due to lack of origin verification

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

Next.js is a React framework for building full-stack web applications. In versions starting from 13.0 to before 14.2.30 and 15.0.0 to before 15.2.2, Next.js may have allowed limited source code exposure when the dev server was running with the App Router enabled. The vulnerability only affects local development environments and requires the user to visit a malicious webpage while npm run dev is active. This issue has been patched in versions 14.2.30 and 15.2.2.

CVSS 2.3 · Baja · EPSS 0,2% · Corrección disponible

Publicación
Actualización

Pila tecnológica: node

Productos y versiones afectados

  • next.js

    Versiones
    • >= 13.0, < 14.2.30: Afectada
    • >= 15.0.0, < 15.2.2: Afectada

    Sin corrección publicada

  • next npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 15.0.0, < 15.2.2

    Actualiza a 15.2.2

  • next npm

    Intervalos de versiones afectados
    • ECOSYSTEM: ≥ 13.0, < 14.2.30

    Actualiza a 14.2.30

Fuentes originales

Comprueba tu servidor →