p PatchFirst

CVE-2025-48068

CVE-2025-48068 · Information exposure in Next.js dev server due to lack of origin verification

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Next.js is a React framework for building full-stack web applications. In versions starting from 13.0 to before 14.2.30 and 15.0.0 to before 15.2.2, Next.js may have allowed limited source code exposure when the dev server was running with the App Router enabled. The vulnerability only affects local development environments and requires the user to visit a malicious webpage while npm run dev is active. This issue has been patched in versions 14.2.30 and 15.2.2.

CVSS 2.3 · Low · EPSS 0.2% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • next.js

    Versions
    • >= 13.0, < 14.2.30: Affected
    • >= 15.0.0, < 15.2.2: Affected

    No fix published

  • next npm

    Affected ranges
    • SEMVER: ≥ 15.0.0, < 15.2.2

    Update to 15.2.2

  • next npm

    Affected ranges
    • ECOSYSTEM: ≥ 13.0, < 14.2.30

    Update to 14.2.30

Original sources

Check your server →