p PatchFirst

CVE-2025-48068

CVE-2025-48068 · Information exposure in Next.js dev server due to lack of origin verification

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Next.js is a React framework for building full-stack web applications. In versions starting from 13.0 to before 14.2.30 and 15.0.0 to before 15.2.2, Next.js may have allowed limited source code exposure when the dev server was running with the App Router enabled. The vulnerability only affects local development environments and requires the user to visit a malicious webpage while npm run dev is active. This issue has been patched in versions 14.2.30 and 15.2.2.

CVSS 2.3 · Niedrig · EPSS 0,2% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: node

Betroffene Produkte und Versionen

  • next.js

    Softwareversionen
    • >= 13.0, < 14.2.30: Betroffen
    • >= 15.0.0, < 15.2.2: Betroffen

    Keine Korrektur veröffentlicht

  • next npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 15.0.0, < 15.2.2

    Auf 15.2.2 aktualisieren

  • next npm

    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 13.0, < 14.2.30

    Auf 14.2.30 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →