p PatchFirst

CVE-2025-5175

CVE-2025-5175 · erdogant pypickle pypickle.py save improper authorization

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

A vulnerability was found in erdogant pypickle up to 1.1.5. It has been classified as critical. This affects the function Save of the file pypickle/pypickle.py. The manipulation leads to improper authorization. Attacking locally is a requirement. The exploit has been disclosed to the public and may be used. Upgrading to version 2.0.0 is able to address this issue. The patch is named 14b4cae704a0bb4eb6723e238f25382d847a1917. It is recommended to upgrade the affected component.

CVSS 4.8 · Media · EPSS 0,2% · Corrección disponible

Publicación
Actualización

Pila tecnológica: python

Productos y versiones afectados

  • pypickle

    Versiones
    • 1.1.0: Afectada
    • 1.1.1: Afectada
    • 1.1.2: Afectada
    • 1.1.3: Afectada
    • 1.1.4: Afectada
    • 1.1.5: Afectada

    Sin corrección publicada

  • pypickle PyPI

    Versiones
    • 0.1.0
    • 0.1.1
    • 1.0.0
    • 1.1.0
    • 1.1.1
    • 1.1.3
    • 1.1.4
    • 1.1.5
    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.0.0

    Actualiza a 2.0.0

  • pypickle PyPI

    Versiones
    • 0.1.0
    • 0.1.1
    • 1.0.0
    • 1.1.0
    • 1.1.1
    • 1.1.3
    • 1.1.4
    • 1.1.5
    • 1.1.2
    Intervalos de versiones afectados
    • {"events": [{"introduced": "0"}, {"fixed": "14b4cae704a0bb4eb6723e238f25382d847a1917"}, {"fixed": "5058ea8c0666b3f8d30893be5c0132ad7fb7bf39"}], "repo": "https://github.com/erdogant/pypickle", "type": "GIT"}
    • ECOSYSTEM: < 2.0.0

    Actualiza a 2.0.0

Fuentes originales

Comprueba tu servidor →