p PatchFirst

CVE-2025-5175

CVE-2025-5175 · erdogant pypickle pypickle.py save improper authorization

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

A vulnerability was found in erdogant pypickle up to 1.1.5. It has been classified as critical. This affects the function Save of the file pypickle/pypickle.py. The manipulation leads to improper authorization. Attacking locally is a requirement. The exploit has been disclosed to the public and may be used. Upgrading to version 2.0.0 is able to address this issue. The patch is named 14b4cae704a0bb4eb6723e238f25382d847a1917. It is recommended to upgrade the affected component.

CVSS 4.8 · Mittel · EPSS 0,2% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: python

Betroffene Produkte und Versionen

  • pypickle

    Softwareversionen
    • 1.1.0: Betroffen
    • 1.1.1: Betroffen
    • 1.1.2: Betroffen
    • 1.1.3: Betroffen
    • 1.1.4: Betroffen
    • 1.1.5: Betroffen

    Keine Korrektur veröffentlicht

  • pypickle PyPI

    Softwareversionen
    • 0.1.0
    • 0.1.1
    • 1.0.0
    • 1.1.0
    • 1.1.1
    • 1.1.3
    • 1.1.4
    • 1.1.5
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.0.0

    Auf 2.0.0 aktualisieren

  • pypickle PyPI

    Softwareversionen
    • 0.1.0
    • 0.1.1
    • 1.0.0
    • 1.1.0
    • 1.1.1
    • 1.1.3
    • 1.1.4
    • 1.1.5
    • 1.1.2
    Betroffene Versionsbereiche
    • {"events": [{"introduced": "0"}, {"fixed": "14b4cae704a0bb4eb6723e238f25382d847a1917"}, {"fixed": "5058ea8c0666b3f8d30893be5c0132ad7fb7bf39"}], "repo": "https://github.com/erdogant/pypickle", "type": "GIT"}
    • ECOSYSTEM: < 2.0.0

    Auf 2.0.0 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →