p PatchFirst

CVE-2025-5175

CVE-2025-5175 · erdogant pypickle pypickle.py save improper authorization

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

A vulnerability was found in erdogant pypickle up to 1.1.5. It has been classified as critical. This affects the function Save of the file pypickle/pypickle.py. The manipulation leads to improper authorization. Attacking locally is a requirement. The exploit has been disclosed to the public and may be used. Upgrading to version 2.0.0 is able to address this issue. The patch is named 14b4cae704a0bb4eb6723e238f25382d847a1917. It is recommended to upgrade the affected component.

CVSS 4.8 · Moyenne · EPSS 0,2% · Correctif disponible

Publication
Mise à jour

Pile logicielle: python

Produits et versions concernés

  • pypickle

    Versions du logiciel
    • 1.1.0: Concernée
    • 1.1.1: Concernée
    • 1.1.2: Concernée
    • 1.1.3: Concernée
    • 1.1.4: Concernée
    • 1.1.5: Concernée

    Aucun correctif publié

  • pypickle PyPI

    Versions du logiciel
    • 0.1.0
    • 0.1.1
    • 1.0.0
    • 1.1.0
    • 1.1.1
    • 1.1.3
    • 1.1.4
    • 1.1.5
    Plages de versions concernées
    • ECOSYSTEM: < 2.0.0

    Mettez à jour vers 2.0.0

  • pypickle PyPI

    Versions du logiciel
    • 0.1.0
    • 0.1.1
    • 1.0.0
    • 1.1.0
    • 1.1.1
    • 1.1.3
    • 1.1.4
    • 1.1.5
    • 1.1.2
    Plages de versions concernées
    • {"events": [{"introduced": "0"}, {"fixed": "14b4cae704a0bb4eb6723e238f25382d847a1917"}, {"fixed": "5058ea8c0666b3f8d30893be5c0132ad7fb7bf39"}], "repo": "https://github.com/erdogant/pypickle", "type": "GIT"}
    • ECOSYSTEM: < 2.0.0

    Mettez à jour vers 2.0.0

Sources originales

Vérifiez votre serveur →