CVE-2025-54869
CVE-2025-54869 · FPDI is Vulnerable to Memory Exhaustion (OOM) through its PDF Parser
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
FPDI is a collection of PHP classes that facilitate reading pages from existing PDF documents and using them as templates in FPDF. In versions 2.6.2 and below, any application that uses FPDI to process user-supplied PDF files is at risk, causing a Denial of Service (DoS) vulnerability. An attacker can upload a small, malicious PDF file that will cause the server-side script to crash due to memory exhaustion. Repeated attacks can lead to sustained service unavailability. This issue is fixed in version 2.6.3.
CVSS 6.0 · Media · EPSS 0,3% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · php
Productos y versiones afectados
fpdi
- Versiones
- < 2.6.3: Afectada
Sin corrección publicada
icingaweb2-module-pdfexport Debian:12
- Versiones
- 0.10.2+dfsg1-2
- 0.10.2+dfsg1-3
- 0.10.2+dfsg1-4
- 0.11.0+dfsg-1
- 0.11.0+dfsg-2
- 0.11.0+dfsg-3
- 0.12.0+dfsg-1
- 0.12.0+dfsg-2
- 0.13.0+dfsg-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
icingaweb2-module-pdfexport Debian:13
- Versiones
- 0.11.0+dfsg-3
- 0.12.0+dfsg-1
- 0.12.0+dfsg-2
- 0.13.0+dfsg-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
icingaweb2-module-pdfexport Debian:14
- Versiones
- 0.11.0+dfsg-3
- 0.12.0+dfsg-1
- 0.12.0+dfsg-2
- 0.13.0+dfsg-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
setasign/fpdi Packagist
- Versiones
- 1.5.2
- 1.5.3
- 1.5.4
- 1.6.0
- 1.6.1
- 1.6.2
- v2.0.0
- v2.0.0-beta
- v2.0.0-beta2
- v2.0.0-rc1
- v2.0.1
- v2.0.2
- v2.0.3
- v2.1.0
- v2.1.1
- v2.2.0
- v2.3.0
- v2.3.1
- v2.3.2
- v2.3.3
- v2.3.4
- v2.3.5
- v2.3.6
- v2.3.7
- v2.4.0
- v2.4.1
- v2.5.0
- v2.6.0
- v2.6.1
- v2.6.2
- v2.6.3
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.6.4
Actualiza a 2.6.4
icingaweb2-module-pdfexport Ubuntu:22.04:LTS
- Versiones
- 0.9.1-1
- 0.9.1-2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
icingaweb2-module-pdfexport Ubuntu:24.04:LTS
- Versiones
- 0.10.2+dfsg1-2
- 0.10.2+dfsg1-3
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
icingaweb2-module-pdfexport Ubuntu:25.10
- Versiones
- 0.11.0+dfsg-2
- 0.11.0+dfsg-3
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
icingaweb2-module-pdfexport Ubuntu:26.10
- Versiones
- 0.12.0+dfsg-2
- 0.13.0+dfsg-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
icingaweb2-module-pdfexport Ubuntu:26.04:LTS
- Versiones
- 0.11.0+dfsg-3
- 0.12.0+dfsg-1
- 0.12.0+dfsg-2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada