p PatchFirst

CVE-2025-54869

CVE-2025-54869 · FPDI is Vulnerable to Memory Exhaustion (OOM) through its PDF Parser

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

FPDI is a collection of PHP classes that facilitate reading pages from existing PDF documents and using them as templates in FPDF. In versions 2.6.2 and below, any application that uses FPDI to process user-supplied PDF files is at risk, causing a Denial of Service (DoS) vulnerability. An attacker can upload a small, malicious PDF file that will cause the server-side script to crash due to memory exhaustion. Repeated attacks can lead to sustained service unavailability. This issue is fixed in version 2.6.3.

CVSS 6.0 · Mittel · EPSS 0,3% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system · php

Betroffene Produkte und Versionen

  • fpdi

    Softwareversionen
    • < 2.6.3: Betroffen

    Keine Korrektur veröffentlicht

  • icingaweb2-module-pdfexport Debian:12

    Softwareversionen
    • 0.10.2+dfsg1-2
    • 0.10.2+dfsg1-3
    • 0.10.2+dfsg1-4
    • 0.11.0+dfsg-1
    • 0.11.0+dfsg-2
    • 0.11.0+dfsg-3
    • 0.12.0+dfsg-1
    • 0.12.0+dfsg-2
    • 0.13.0+dfsg-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • icingaweb2-module-pdfexport Debian:13

    Softwareversionen
    • 0.11.0+dfsg-3
    • 0.12.0+dfsg-1
    • 0.12.0+dfsg-2
    • 0.13.0+dfsg-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • icingaweb2-module-pdfexport Debian:14

    Softwareversionen
    • 0.11.0+dfsg-3
    • 0.12.0+dfsg-1
    • 0.12.0+dfsg-2
    • 0.13.0+dfsg-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • setasign/fpdi Packagist

    Softwareversionen
    • 1.5.2
    • 1.5.3
    • 1.5.4
    • 1.6.0
    • 1.6.1
    • 1.6.2
    • v2.0.0
    • v2.0.0-beta
    • v2.0.0-beta2
    • v2.0.0-rc1
    • v2.0.1
    • v2.0.2
    • v2.0.3
    • v2.1.0
    • v2.1.1
    • v2.2.0
    • v2.3.0
    • v2.3.1
    • v2.3.2
    • v2.3.3
    • v2.3.4
    • v2.3.5
    • v2.3.6
    • v2.3.7
    • v2.4.0
    • v2.4.1
    • v2.5.0
    • v2.6.0
    • v2.6.1
    • v2.6.2
    • v2.6.3
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.6.4

    Auf 2.6.4 aktualisieren

  • icingaweb2-module-pdfexport Ubuntu:22.04:LTS

    Softwareversionen
    • 0.9.1-1
    • 0.9.1-2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • icingaweb2-module-pdfexport Ubuntu:24.04:LTS

    Softwareversionen
    • 0.10.2+dfsg1-2
    • 0.10.2+dfsg1-3
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • icingaweb2-module-pdfexport Ubuntu:25.10

    Softwareversionen
    • 0.11.0+dfsg-2
    • 0.11.0+dfsg-3
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • icingaweb2-module-pdfexport Ubuntu:26.10

    Softwareversionen
    • 0.12.0+dfsg-2
    • 0.13.0+dfsg-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • icingaweb2-module-pdfexport Ubuntu:26.04:LTS

    Softwareversionen
    • 0.11.0+dfsg-3
    • 0.12.0+dfsg-1
    • 0.12.0+dfsg-2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →