p PatchFirst

PatchFirst · Vulnerabilidades recientes

Vulnerabilidades de setasign/fpdi

Vulnerabilidades publicadas para setasign/fpdi en los últimos 30 días: 0. Incluidas en el catálogo KEV: 0.

Filtrar vulnerabilidades
Borrar filtros

Vulnerabilidades: 2

  1. CVE-2026-45802

    Media · CVSS 6EPSS 0,26%Corrección disponible

    FPDI: Memory Exhaustion and Endless Loop in FPDI leads to Denial of Service

    FPDI is a collection of PHP classes that facilitate reading pages from existing PDF documents and using them as templates in FPDF. Prior to version 2.6.7, an attacker can upload a small, malicious PDF file that will cause the server-side script to crash due to memory exhaustion or a script time-out. Repeated attacks can lead to sustained service unavailability. This issue has been patched in version 2.6.7.

    • Actualiza a 2.6.7
    Publicación Actualización
  2. CVE-2025-54869

    Media · CVSS 6EPSS 0,33%Corrección disponible

    FPDI is Vulnerable to Memory Exhaustion (OOM) through its PDF Parser

    FPDI is a collection of PHP classes that facilitate reading pages from existing PDF documents and using them as templates in FPDF. In versions 2.6.2 and below, any application that uses FPDI to process user-supplied PDF files is at risk, causing a Denial of Service (DoS) vulnerability. An attacker can upload a small, malicious PDF file that will cause the server-side script to crash due to memory exhaustion. Repeated attacks can lead to sustained service unavailability. This issue is fixed in version 2.6.3.

    • Actualiza a 2.6.4
    Publicación Actualización

Comprueba tu servidor

Compara tu pila y las versiones instaladas con las bases actuales de vulnerabilidades.

Comprueba tu servidor →