p PatchFirst

CVE-2025-55173

CVE-2025-55173 · Next.js Content Injection Vulnerability for Image Optimization

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

Next.js is a React framework for building full-stack web applications. In versions before 14.2.31 and from 15.0.0 to before 15.4.5, Next.js Image Optimization is vulnerable to content injection. The issue allowed attacker-controlled external image sources to trigger file downloads with arbitrary content and filenames under specific configurations. This behavior could be abused for phishing or malicious file delivery. This vulnerability has been fixed in Next.js versions 14.2.31 and 15.4.5.

CVSS 4.3 · Media · EPSS 0,6% · Corrección disponible

Publicación
Actualización

Pila tecnológica: node

Productos y versiones afectados

  • next.js

    Versiones
    • >= 15.0.0, < 15.4.5: Afectada
    • < 14.2.31: Afectada

    Sin corrección publicada

  • next npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 0.9.9, < 14.2.31

    Actualiza a 14.2.31

  • next npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 15.0.0, < 15.4.5

    Actualiza a 15.4.5

Fuentes originales

Comprueba tu servidor →