p PatchFirst

CVE-2025-55173

CVE-2025-55173 · Next.js Content Injection Vulnerability for Image Optimization

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

Next.js is a React framework for building full-stack web applications. In versions before 14.2.31 and from 15.0.0 to before 15.4.5, Next.js Image Optimization is vulnerable to content injection. The issue allowed attacker-controlled external image sources to trigger file downloads with arbitrary content and filenames under specific configurations. This behavior could be abused for phishing or malicious file delivery. This vulnerability has been fixed in Next.js versions 14.2.31 and 15.4.5.

CVSS 4.3 · Moyenne · EPSS 0,6% · Correctif disponible

Publication
Mise à jour

Pile logicielle: node

Produits et versions concernés

  • next.js

    Versions du logiciel
    • >= 15.0.0, < 15.4.5: Concernée
    • < 14.2.31: Concernée

    Aucun correctif publié

  • next npm

    Plages de versions concernées
    • SEMVER: ≥ 0.9.9, < 14.2.31

    Mettez à jour vers 14.2.31

  • next npm

    Plages de versions concernées
    • SEMVER: ≥ 15.0.0, < 15.4.5

    Mettez à jour vers 15.4.5

Sources originales

Vérifiez votre serveur →