p PatchFirst

CVE-2025-55173

CVE-2025-55173 · Next.js Content Injection Vulnerability for Image Optimization

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Next.js is a React framework for building full-stack web applications. In versions before 14.2.31 and from 15.0.0 to before 15.4.5, Next.js Image Optimization is vulnerable to content injection. The issue allowed attacker-controlled external image sources to trigger file downloads with arbitrary content and filenames under specific configurations. This behavior could be abused for phishing or malicious file delivery. This vulnerability has been fixed in Next.js versions 14.2.31 and 15.4.5.

CVSS 4.3 · Mittel · EPSS 0,6% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: node

Betroffene Produkte und Versionen

  • next.js

    Softwareversionen
    • >= 15.0.0, < 15.4.5: Betroffen
    • < 14.2.31: Betroffen

    Keine Korrektur veröffentlicht

  • next npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 0.9.9, < 14.2.31

    Auf 14.2.31 aktualisieren

  • next npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 15.0.0, < 15.4.5

    Auf 15.4.5 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →