p PatchFirst

CVE-2025-57822

CVE-2025-57822 · Next.js Improper Middleware Redirect Handling Leads to SSRF

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

Next.js is a React framework for building full-stack web applications. Prior to versions 14.2.32 and 15.4.7, when next() was used without explicitly passing the request object, it could lead to SSRF in self-hosted applications that incorrectly forwarded user-supplied headers. This vulnerability has been fixed in Next.js versions 14.2.32 and 15.4.7. All users implementing custom middleware logic in self-hosted environments are strongly encouraged to upgrade and verify correct usage of the next() function.

CVSS 6.5 · Media · EPSS 2,6% · Código de explotación público · Corrección disponible

Publicación
Actualización

Pila tecnológica: node

Productos y versiones afectados

  • next.js

    Versiones
    • < 14.2.32: Afectada
    • < 15.4.7: Afectada

    Sin corrección publicada

  • next npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 0.9.9, < 14.2.32

    Actualiza a 14.2.32

  • next npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 15.0.0-canary.0, < 15.4.7

    Actualiza a 15.4.7

Fuentes originales

Comprueba tu servidor →