p PatchFirst

CVE-2025-57822

CVE-2025-57822 · Next.js Improper Middleware Redirect Handling Leads to SSRF

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Next.js is a React framework for building full-stack web applications. Prior to versions 14.2.32 and 15.4.7, when next() was used without explicitly passing the request object, it could lead to SSRF in self-hosted applications that incorrectly forwarded user-supplied headers. This vulnerability has been fixed in Next.js versions 14.2.32 and 15.4.7. All users implementing custom middleware logic in self-hosted environments are strongly encouraged to upgrade and verify correct usage of the next() function.

CVSS 6.5 · Mittel · EPSS 2,6% · Öffentlicher Exploit · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: node

Betroffene Produkte und Versionen

  • next.js

    Softwareversionen
    • < 14.2.32: Betroffen
    • < 15.4.7: Betroffen

    Keine Korrektur veröffentlicht

  • next npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 0.9.9, < 14.2.32

    Auf 14.2.32 aktualisieren

  • next npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 15.0.0-canary.0, < 15.4.7

    Auf 15.4.7 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →