p PatchFirst

CVE-2025-57822

CVE-2025-57822 · Next.js Improper Middleware Redirect Handling Leads to SSRF

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

Next.js is a React framework for building full-stack web applications. Prior to versions 14.2.32 and 15.4.7, when next() was used without explicitly passing the request object, it could lead to SSRF in self-hosted applications that incorrectly forwarded user-supplied headers. This vulnerability has been fixed in Next.js versions 14.2.32 and 15.4.7. All users implementing custom middleware logic in self-hosted environments are strongly encouraged to upgrade and verify correct usage of the next() function.

CVSS 6.5 · Moyenne · EPSS 2,6% · Code d’exploitation public · Correctif disponible

Publication
Mise à jour

Pile logicielle: node

Produits et versions concernés

  • next.js

    Versions du logiciel
    • < 14.2.32: Concernée
    • < 15.4.7: Concernée

    Aucun correctif publié

  • next npm

    Plages de versions concernées
    • SEMVER: ≥ 0.9.9, < 14.2.32

    Mettez à jour vers 14.2.32

  • next npm

    Plages de versions concernées
    • SEMVER: ≥ 15.0.0-canary.0, < 15.4.7

    Mettez à jour vers 15.4.7

Sources originales

Vérifiez votre serveur →