CVE-2025-58057
CVE-2025-58057 · Netty's BrotliDecoder is vulnerable to DoS via zip bomb style attack
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
Netty is an asynchronous event-driven network application framework for rapid development of maintainable high performance protocol servers & clients. In netty-codec-compression versions 4.1.124.Final and below, and netty-codec versions 4.2.4.Final and below, when supplied with specially crafted input, BrotliDecoder and certain other decompression decoders will allocate a large number of reachable byte buffers, which can lead to denial of service. BrotliDecoder.decompress has no limit in how often it calls pull, decompressing data 64K bytes at a time. The buffers are saved in the output list, and remain reachable until OOM is hit. This is fixed in versions 4.1.125.Final of netty-codec and 4.2.5.Final of netty-codec-compression.
CVSS 6.9 · Media · EPSS 0,6% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system
Productos y versiones afectados
netty
- Versiones
- <= 4.1.124.Final, < 4.1.125.Final: Afectada
- <= 4.2.4.Final, < 4.2.5.Final: Afectada
Sin corrección publicada
netty Debian:12
- Versiones
- 1:4.1.48-7
- 1:4.1.48-7+deb12u1
- Intervalos de versiones afectados
- ECOSYSTEM: < 1:4.1.48-7+deb12u2
Actualiza a 1:4.1.48-7+deb12u2
netty Debian:13
- Versiones
- 1:4.1.48-10
- Intervalos de versiones afectados
- ECOSYSTEM: < 1:4.1.48-10+deb13u1
Actualiza a 1:4.1.48-10+deb13u1
netty Debian:14
- Versiones
- 1:4.1.48-10
- 1:4.1.48-11
- Intervalos de versiones afectados
- ECOSYSTEM: < 1:4.1.48-12
Actualiza a 1:4.1.48-12
netty Ubuntu:Pro:14.04:LTS
- Versiones
- 1:3.2.6.Final-2
- 1:3.2.6.Final-2+deb8u2build0.14.04.1~esm1
- 1:3.2.6.Final-2+deb8u2ubuntu0.1~esm1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
netty Ubuntu:Pro:16.04:LTS
- Versiones
- 1:3.2.6.Final-2
- 1:4.0.32-1
- 1:4.0.33-1
- 1:4.0.34-1
- 1:4.0.34-1ubuntu0.1~esm1
- 1:4.0.34-1ubuntu0.1~esm2
- 1:4.0.34-1ubuntu0.1~esm3
- 1:4.0.34-1ubuntu0.1~esm4
- 1:4.0.34-1ubuntu0.1~esm5
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
netty Ubuntu:Pro:18.04:LTS
- Versiones
- 1:4.1.7-4
- 1:4.1.7-4ubuntu0.1~esm1
- 1:4.1.7-4ubuntu0.1
- 1:4.1.7-4ubuntu0.1+esm1
- 1:4.1.7-4ubuntu0.1+esm2
- 1:4.1.7-4ubuntu0.1+esm3
- 1:4.1.7-4ubuntu0.1+esm4
- Intervalos de versiones afectados
- ECOSYSTEM: < 1:4.1.7-4ubuntu0.1+esm5
Actualiza a 1:4.1.7-4ubuntu0.1+esm5
netty Ubuntu:Pro:20.04:LTS
- Versiones
- 1:4.1.33-1
- 1:4.1.33-2
- 1:4.1.33-3
- 1:4.1.45-1
- 1:4.1.45-1ubuntu0.1~esm1
- 1:4.1.45-1ubuntu0.1~esm2
- 1:4.1.45-1ubuntu0.1~esm3
- Intervalos de versiones afectados
- ECOSYSTEM: < 1:4.1.45-1ubuntu0.1~esm4
Actualiza a 1:4.1.45-1ubuntu0.1~esm4
netty Ubuntu:22.04:LTS
- Versiones
- 1:4.1.48-4
- 1:4.1.48-4+deb11u1build0.22.04.1
- 1:4.1.48-4+deb11u2build0.22.04.1
- Intervalos de versiones afectados
- ECOSYSTEM: < 1:4.1.48-4+deb11u2ubuntu0.1
Actualiza a 1:4.1.48-4+deb11u2ubuntu0.1
netty Ubuntu:24.04:LTS
- Versiones
- 1:4.1.48-7
- 1:4.1.48-8
- 1:4.1.48-9
- Intervalos de versiones afectados
- ECOSYSTEM: < 1:4.1.48-9ubuntu0.1
Actualiza a 1:4.1.48-9ubuntu0.1
netty Ubuntu:25.10
- Versiones
- 1:4.1.48-10
- 1:4.1.48-10ubuntu0.25.10.1
- Intervalos de versiones afectados
- ECOSYSTEM: < 1:4.1.48-10ubuntu0.25.10.2
Actualiza a 1:4.1.48-10ubuntu0.25.10.2