CVE-2025-58057
CVE-2025-58057 · Netty's BrotliDecoder is vulnerable to DoS via zip bomb style attack
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
Netty is an asynchronous event-driven network application framework for rapid development of maintainable high performance protocol servers & clients. In netty-codec-compression versions 4.1.124.Final and below, and netty-codec versions 4.2.4.Final and below, when supplied with specially crafted input, BrotliDecoder and certain other decompression decoders will allocate a large number of reachable byte buffers, which can lead to denial of service. BrotliDecoder.decompress has no limit in how often it calls pull, decompressing data 64K bytes at a time. The buffers are saved in the output list, and remain reachable until OOM is hit. This is fixed in versions 4.1.125.Final of netty-codec and 4.2.5.Final of netty-codec-compression.
CVSS 6.9 · Moyenne · EPSS 0,6% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system
Produits et versions concernés
netty
- Versions du logiciel
- <= 4.1.124.Final, < 4.1.125.Final: Concernée
- <= 4.2.4.Final, < 4.2.5.Final: Concernée
Aucun correctif publié
netty Debian:12
- Versions du logiciel
- 1:4.1.48-7
- 1:4.1.48-7+deb12u1
- Plages de versions concernées
- ECOSYSTEM: < 1:4.1.48-7+deb12u2
Mettez à jour vers 1:4.1.48-7+deb12u2
netty Debian:13
- Versions du logiciel
- 1:4.1.48-10
- Plages de versions concernées
- ECOSYSTEM: < 1:4.1.48-10+deb13u1
Mettez à jour vers 1:4.1.48-10+deb13u1
netty Debian:14
- Versions du logiciel
- 1:4.1.48-10
- 1:4.1.48-11
- Plages de versions concernées
- ECOSYSTEM: < 1:4.1.48-12
Mettez à jour vers 1:4.1.48-12
netty Ubuntu:Pro:14.04:LTS
- Versions du logiciel
- 1:3.2.6.Final-2
- 1:3.2.6.Final-2+deb8u2build0.14.04.1~esm1
- 1:3.2.6.Final-2+deb8u2ubuntu0.1~esm1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
netty Ubuntu:Pro:16.04:LTS
- Versions du logiciel
- 1:3.2.6.Final-2
- 1:4.0.32-1
- 1:4.0.33-1
- 1:4.0.34-1
- 1:4.0.34-1ubuntu0.1~esm1
- 1:4.0.34-1ubuntu0.1~esm2
- 1:4.0.34-1ubuntu0.1~esm3
- 1:4.0.34-1ubuntu0.1~esm4
- 1:4.0.34-1ubuntu0.1~esm5
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
netty Ubuntu:Pro:18.04:LTS
- Versions du logiciel
- 1:4.1.7-4
- 1:4.1.7-4ubuntu0.1~esm1
- 1:4.1.7-4ubuntu0.1
- 1:4.1.7-4ubuntu0.1+esm1
- 1:4.1.7-4ubuntu0.1+esm2
- 1:4.1.7-4ubuntu0.1+esm3
- 1:4.1.7-4ubuntu0.1+esm4
- Plages de versions concernées
- ECOSYSTEM: < 1:4.1.7-4ubuntu0.1+esm5
Mettez à jour vers 1:4.1.7-4ubuntu0.1+esm5
netty Ubuntu:Pro:20.04:LTS
- Versions du logiciel
- 1:4.1.33-1
- 1:4.1.33-2
- 1:4.1.33-3
- 1:4.1.45-1
- 1:4.1.45-1ubuntu0.1~esm1
- 1:4.1.45-1ubuntu0.1~esm2
- 1:4.1.45-1ubuntu0.1~esm3
- Plages de versions concernées
- ECOSYSTEM: < 1:4.1.45-1ubuntu0.1~esm4
Mettez à jour vers 1:4.1.45-1ubuntu0.1~esm4
netty Ubuntu:22.04:LTS
- Versions du logiciel
- 1:4.1.48-4
- 1:4.1.48-4+deb11u1build0.22.04.1
- 1:4.1.48-4+deb11u2build0.22.04.1
- Plages de versions concernées
- ECOSYSTEM: < 1:4.1.48-4+deb11u2ubuntu0.1
Mettez à jour vers 1:4.1.48-4+deb11u2ubuntu0.1
netty Ubuntu:24.04:LTS
- Versions du logiciel
- 1:4.1.48-7
- 1:4.1.48-8
- 1:4.1.48-9
- Plages de versions concernées
- ECOSYSTEM: < 1:4.1.48-9ubuntu0.1
Mettez à jour vers 1:4.1.48-9ubuntu0.1
netty Ubuntu:25.10
- Versions du logiciel
- 1:4.1.48-10
- 1:4.1.48-10ubuntu0.25.10.1
- Plages de versions concernées
- ECOSYSTEM: < 1:4.1.48-10ubuntu0.25.10.2
Mettez à jour vers 1:4.1.48-10ubuntu0.25.10.2