CVE-2025-58057
CVE-2025-58057 · Netty's BrotliDecoder is vulnerable to DoS via zip bomb style attack
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
Netty is an asynchronous event-driven network application framework for rapid development of maintainable high performance protocol servers & clients. In netty-codec-compression versions 4.1.124.Final and below, and netty-codec versions 4.2.4.Final and below, when supplied with specially crafted input, BrotliDecoder and certain other decompression decoders will allocate a large number of reachable byte buffers, which can lead to denial of service. BrotliDecoder.decompress has no limit in how often it calls pull, decompressing data 64K bytes at a time. The buffers are saved in the output list, and remain reachable until OOM is hit. This is fixed in versions 4.1.125.Final of netty-codec and 4.2.5.Final of netty-codec-compression.
CVSS 6.9 · Mittel · EPSS 0,6% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system
Betroffene Produkte und Versionen
netty
- Softwareversionen
- <= 4.1.124.Final, < 4.1.125.Final: Betroffen
- <= 4.2.4.Final, < 4.2.5.Final: Betroffen
Keine Korrektur veröffentlicht
netty Debian:12
- Softwareversionen
- 1:4.1.48-7
- 1:4.1.48-7+deb12u1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1:4.1.48-7+deb12u2
Auf 1:4.1.48-7+deb12u2 aktualisieren
netty Debian:13
- Softwareversionen
- 1:4.1.48-10
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1:4.1.48-10+deb13u1
Auf 1:4.1.48-10+deb13u1 aktualisieren
netty Debian:14
- Softwareversionen
- 1:4.1.48-10
- 1:4.1.48-11
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1:4.1.48-12
Auf 1:4.1.48-12 aktualisieren
netty Ubuntu:Pro:14.04:LTS
- Softwareversionen
- 1:3.2.6.Final-2
- 1:3.2.6.Final-2+deb8u2build0.14.04.1~esm1
- 1:3.2.6.Final-2+deb8u2ubuntu0.1~esm1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
netty Ubuntu:Pro:16.04:LTS
- Softwareversionen
- 1:3.2.6.Final-2
- 1:4.0.32-1
- 1:4.0.33-1
- 1:4.0.34-1
- 1:4.0.34-1ubuntu0.1~esm1
- 1:4.0.34-1ubuntu0.1~esm2
- 1:4.0.34-1ubuntu0.1~esm3
- 1:4.0.34-1ubuntu0.1~esm4
- 1:4.0.34-1ubuntu0.1~esm5
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
netty Ubuntu:Pro:18.04:LTS
- Softwareversionen
- 1:4.1.7-4
- 1:4.1.7-4ubuntu0.1~esm1
- 1:4.1.7-4ubuntu0.1
- 1:4.1.7-4ubuntu0.1+esm1
- 1:4.1.7-4ubuntu0.1+esm2
- 1:4.1.7-4ubuntu0.1+esm3
- 1:4.1.7-4ubuntu0.1+esm4
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1:4.1.7-4ubuntu0.1+esm5
Auf 1:4.1.7-4ubuntu0.1+esm5 aktualisieren
netty Ubuntu:Pro:20.04:LTS
- Softwareversionen
- 1:4.1.33-1
- 1:4.1.33-2
- 1:4.1.33-3
- 1:4.1.45-1
- 1:4.1.45-1ubuntu0.1~esm1
- 1:4.1.45-1ubuntu0.1~esm2
- 1:4.1.45-1ubuntu0.1~esm3
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1:4.1.45-1ubuntu0.1~esm4
Auf 1:4.1.45-1ubuntu0.1~esm4 aktualisieren
netty Ubuntu:22.04:LTS
- Softwareversionen
- 1:4.1.48-4
- 1:4.1.48-4+deb11u1build0.22.04.1
- 1:4.1.48-4+deb11u2build0.22.04.1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1:4.1.48-4+deb11u2ubuntu0.1
Auf 1:4.1.48-4+deb11u2ubuntu0.1 aktualisieren
netty Ubuntu:24.04:LTS
- Softwareversionen
- 1:4.1.48-7
- 1:4.1.48-8
- 1:4.1.48-9
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1:4.1.48-9ubuntu0.1
Auf 1:4.1.48-9ubuntu0.1 aktualisieren
netty Ubuntu:25.10
- Softwareversionen
- 1:4.1.48-10
- 1:4.1.48-10ubuntu0.25.10.1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1:4.1.48-10ubuntu0.25.10.2
Auf 1:4.1.48-10ubuntu0.25.10.2 aktualisieren