CVE-2025-64718
CVE-2025-64718 · js-yaml has prototype pollution in merge (<<)
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
js-yaml is a JavaScript YAML parser and dumper. In js-yaml before 4.1.1 and 3.14.2, it's possible for an attacker to modify the prototype of the result of a parsed yaml document via prototype pollution (`__proto__`). All users who parse untrusted yaml documents may be impacted. The problem is patched in js-yaml 4.1.1 and 3.14.2. Users can protect against this kind of attack on the server by using `node --disable-proto=delete` or `deno` (in Deno, pollution protection is on by default).
CVSS 5.3 · Media · EPSS 0,4% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · node
Productos y versiones afectados
js-yaml
- Versiones
- >= 4.0.0, < 4.1.1: Afectada
- < 3.14.2: Afectada
Sin corrección publicada
node-js-yaml Debian:12
- Versiones
- 4.1.0+dfsg+~4.0.5-7
- 4.1.1+dfsg+~4.0.9-1
- 4.2.0+~4.0.9-1
- 4.2.0+~4.0.9-2
- 4.3.2+~4.0.9-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-js-yaml Debian:13
- Versiones
- 4.1.0+dfsg+~4.0.5-7
- 4.1.1+dfsg+~4.0.9-1
- 4.2.0+~4.0.9-1
- 4.2.0+~4.0.9-2
- 4.3.2+~4.0.9-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-js-yaml Debian:14
- Versiones
- 4.1.0+dfsg+~4.0.5-7
- Intervalos de versiones afectados
- ECOSYSTEM: < 4.1.1+dfsg+~4.0.9-1
Actualiza a 4.1.1+dfsg+~4.0.9-1
js-yaml npm
- Intervalos de versiones afectados
- SEMVER: ≥ 4.0.0, < 4.1.1
Actualiza a 4.1.1
js-yaml npm
- Intervalos de versiones afectados
- SEMVER: < 3.14.2
Actualiza a 3.14.2
node-js-yaml Ubuntu:18.04:LTS
- Versiones
- 3.9.1+dfsg-1
- 3.10.0+dfsg-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-js-yaml Ubuntu:20.04:LTS
- Versiones
- 3.13.1+dfsg-2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-js-yaml Ubuntu:22.04:LTS
- Versiones
- 3.14.1+dfsg+~3.12.6-2
- 4.1.0+dfsg+~4.0.5-4ubuntu1
- 4.1.0+dfsg+~4.0.5-5
- 4.1.0+dfsg+~4.0.5-6
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-js-yaml Ubuntu:24.04:LTS
- Versiones
- 4.1.0+dfsg+~4.0.5-7
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-js-yaml Ubuntu:25.10
- Versiones
- 4.1.0+dfsg+~4.0.5-7
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-js-yaml Ubuntu:26.10
- Versiones
- 4.1.1+dfsg+~4.0.9-1
- 4.2.0+~4.0.9-1
- 4.2.0+~4.0.9-2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-js-yaml Ubuntu:26.04:LTS
- Versiones
- 4.1.0+dfsg+~4.0.5-7
- 4.1.1+dfsg+~4.0.9-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
Fuentes originales
- https://github.com/nodeca/js-yaml/security/advisories/GHSA-mh29-5h37-fv8m
- https://github.com/nodeca/js-yaml/issues/730#issuecomment-3549635876
- https://github.com/nodeca/js-yaml/commit/383665ff4248ec2192d1274e934462bb30426879
- https://github.com/nodeca/js-yaml/commit/5278870a17454fe8621dbd8c445c412529525266
- https://github.com/advisories/GHSA-mh29-5h37-fv8m
- https://nvd.nist.gov/vuln/detail/CVE-2025-64718