CVE-2025-64718
CVE-2025-64718 · js-yaml has prototype pollution in merge (<<)
This page contains facts from public vulnerability sources. Check the original advisory before updating.
js-yaml is a JavaScript YAML parser and dumper. In js-yaml before 4.1.1 and 3.14.2, it's possible for an attacker to modify the prototype of the result of a parsed yaml document via prototype pollution (`__proto__`). All users who parse untrusted yaml documents may be impacted. The problem is patched in js-yaml 4.1.1 and 3.14.2. Users can protect against this kind of attack on the server by using `node --disable-proto=delete` or `deno` (in Deno, pollution protection is on by default).
CVSS 5.3 · Medium · EPSS 0.4% · Fix available
- Published
- Updated
Affected products and versions
js-yaml
- Versions
- >= 4.0.0, < 4.1.1: Affected
- < 3.14.2: Affected
No fix published
node-js-yaml Debian:12
- Versions
- 4.1.0+dfsg+~4.0.5-7
- 4.1.1+dfsg+~4.0.9-1
- 4.2.0+~4.0.9-1
- 4.2.0+~4.0.9-2
- 4.3.2+~4.0.9-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-js-yaml Debian:13
- Versions
- 4.1.0+dfsg+~4.0.5-7
- 4.1.1+dfsg+~4.0.9-1
- 4.2.0+~4.0.9-1
- 4.2.0+~4.0.9-2
- 4.3.2+~4.0.9-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-js-yaml Debian:14
- Versions
- 4.1.0+dfsg+~4.0.5-7
- Affected ranges
- ECOSYSTEM: < 4.1.1+dfsg+~4.0.9-1
Update to 4.1.1+dfsg+~4.0.9-1
js-yaml npm
- Affected ranges
- SEMVER: ≥ 4.0.0, < 4.1.1
Update to 4.1.1
js-yaml npm
- Affected ranges
- SEMVER: < 3.14.2
Update to 3.14.2
node-js-yaml Ubuntu:18.04:LTS
- Versions
- 3.9.1+dfsg-1
- 3.10.0+dfsg-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-js-yaml Ubuntu:20.04:LTS
- Versions
- 3.13.1+dfsg-2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-js-yaml Ubuntu:22.04:LTS
- Versions
- 3.14.1+dfsg+~3.12.6-2
- 4.1.0+dfsg+~4.0.5-4ubuntu1
- 4.1.0+dfsg+~4.0.5-5
- 4.1.0+dfsg+~4.0.5-6
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-js-yaml Ubuntu:24.04:LTS
- Versions
- 4.1.0+dfsg+~4.0.5-7
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-js-yaml Ubuntu:25.10
- Versions
- 4.1.0+dfsg+~4.0.5-7
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-js-yaml Ubuntu:26.10
- Versions
- 4.1.1+dfsg+~4.0.9-1
- 4.2.0+~4.0.9-1
- 4.2.0+~4.0.9-2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-js-yaml Ubuntu:26.04:LTS
- Versions
- 4.1.0+dfsg+~4.0.5-7
- 4.1.1+dfsg+~4.0.9-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
Original sources
- https://github.com/nodeca/js-yaml/security/advisories/GHSA-mh29-5h37-fv8m
- https://github.com/nodeca/js-yaml/issues/730#issuecomment-3549635876
- https://github.com/nodeca/js-yaml/commit/383665ff4248ec2192d1274e934462bb30426879
- https://github.com/nodeca/js-yaml/commit/5278870a17454fe8621dbd8c445c412529525266
- https://github.com/advisories/GHSA-mh29-5h37-fv8m
- https://nvd.nist.gov/vuln/detail/CVE-2025-64718