CVE-2025-64718
CVE-2025-64718 · js-yaml has prototype pollution in merge (<<)
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
js-yaml is a JavaScript YAML parser and dumper. In js-yaml before 4.1.1 and 3.14.2, it's possible for an attacker to modify the prototype of the result of a parsed yaml document via prototype pollution (`__proto__`). All users who parse untrusted yaml documents may be impacted. The problem is patched in js-yaml 4.1.1 and 3.14.2. Users can protect against this kind of attack on the server by using `node --disable-proto=delete` or `deno` (in Deno, pollution protection is on by default).
CVSS 5.3 · Moyenne · EPSS 0,4% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system · node
Produits et versions concernés
js-yaml
- Versions du logiciel
- >= 4.0.0, < 4.1.1: Concernée
- < 3.14.2: Concernée
Aucun correctif publié
node-js-yaml Debian:12
- Versions du logiciel
- 4.1.0+dfsg+~4.0.5-7
- 4.1.1+dfsg+~4.0.9-1
- 4.2.0+~4.0.9-1
- 4.2.0+~4.0.9-2
- 4.3.2+~4.0.9-1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
node-js-yaml Debian:13
- Versions du logiciel
- 4.1.0+dfsg+~4.0.5-7
- 4.1.1+dfsg+~4.0.9-1
- 4.2.0+~4.0.9-1
- 4.2.0+~4.0.9-2
- 4.3.2+~4.0.9-1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
node-js-yaml Debian:14
- Versions du logiciel
- 4.1.0+dfsg+~4.0.5-7
- Plages de versions concernées
- ECOSYSTEM: < 4.1.1+dfsg+~4.0.9-1
Mettez à jour vers 4.1.1+dfsg+~4.0.9-1
js-yaml npm
- Plages de versions concernées
- SEMVER: ≥ 4.0.0, < 4.1.1
Mettez à jour vers 4.1.1
js-yaml npm
- Plages de versions concernées
- SEMVER: < 3.14.2
Mettez à jour vers 3.14.2
node-js-yaml Ubuntu:18.04:LTS
- Versions du logiciel
- 3.9.1+dfsg-1
- 3.10.0+dfsg-1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
node-js-yaml Ubuntu:20.04:LTS
- Versions du logiciel
- 3.13.1+dfsg-2
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
node-js-yaml Ubuntu:22.04:LTS
- Versions du logiciel
- 3.14.1+dfsg+~3.12.6-2
- 4.1.0+dfsg+~4.0.5-4ubuntu1
- 4.1.0+dfsg+~4.0.5-5
- 4.1.0+dfsg+~4.0.5-6
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
node-js-yaml Ubuntu:24.04:LTS
- Versions du logiciel
- 4.1.0+dfsg+~4.0.5-7
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
node-js-yaml Ubuntu:25.10
- Versions du logiciel
- 4.1.0+dfsg+~4.0.5-7
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
node-js-yaml Ubuntu:26.10
- Versions du logiciel
- 4.1.1+dfsg+~4.0.9-1
- 4.2.0+~4.0.9-1
- 4.2.0+~4.0.9-2
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
node-js-yaml Ubuntu:26.04:LTS
- Versions du logiciel
- 4.1.0+dfsg+~4.0.5-7
- 4.1.1+dfsg+~4.0.9-1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
Sources originales
- https://github.com/nodeca/js-yaml/security/advisories/GHSA-mh29-5h37-fv8m
- https://github.com/nodeca/js-yaml/issues/730#issuecomment-3549635876
- https://github.com/nodeca/js-yaml/commit/383665ff4248ec2192d1274e934462bb30426879
- https://github.com/nodeca/js-yaml/commit/5278870a17454fe8621dbd8c445c412529525266
- https://github.com/advisories/GHSA-mh29-5h37-fv8m
- https://nvd.nist.gov/vuln/detail/CVE-2025-64718