CVE-2025-65944
CVE-2025-65944 · Sentry-Javascript deals with leaked sensitive headers when `sendDefaultPii` is set to `true`
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
Sentry-Javascript is an official Sentry SDKs for JavaScript. From version 10.11.0 to before 10.27.0, when a Node.js application using the Sentry SDK has sendDefaultPii: true it is possible to inadvertently send certain sensitive HTTP headers, including the Cookie header, to Sentry. Those headers would be stored within a Sentry organization as part of the associated trace. A person with access to the Sentry organization could then view and use these sensitive values to impersonate or escalate their privileges within the application. This issue has been patched in version 10.27.0.
CVSS 5.1 · Media · EPSS 0,4% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: node
Productos y versiones afectados
sentry-javascript
- Versiones
- >= 10.11.0, < 10.27.0: Afectada
Sin corrección publicada
@sentry/node npm
- Intervalos de versiones afectados
- SEMVER: ≥ 10.11.0, < 10.27.0
Actualiza a 10.27.0
@sentry/astro npm
- Intervalos de versiones afectados
- SEMVER: ≥ 10.11.0, < 10.27.0
Actualiza a 10.27.0
@sentry/aws-serverless npm
- Intervalos de versiones afectados
- SEMVER: ≥ 10.11.0, < 10.27.0
Actualiza a 10.27.0
@sentry/bun npm
- Intervalos de versiones afectados
- SEMVER: ≥ 10.11.0, < 10.27.0
Actualiza a 10.27.0
@sentry/google-cloud-serverless npm
- Intervalos de versiones afectados
- SEMVER: ≥ 10.11.0, < 10.27.0
Actualiza a 10.27.0
@sentry/nestjs npm
- Intervalos de versiones afectados
- SEMVER: ≥ 10.11.0, < 10.27.0
Actualiza a 10.27.0
@sentry/nextjs npm
- Intervalos de versiones afectados
- SEMVER: ≥ 10.11.0, < 10.27.0
Actualiza a 10.27.0
@sentry/node-core npm
- Intervalos de versiones afectados
- SEMVER: ≥ 10.11.0, < 10.27.0
Actualiza a 10.27.0
@sentry/nuxt npm
- Intervalos de versiones afectados
- SEMVER: ≥ 10.11.0, < 10.27.0
Actualiza a 10.27.0
@sentry/remix npm
- Intervalos de versiones afectados
- SEMVER: ≥ 10.11.0, < 10.27.0
Actualiza a 10.27.0
@sentry/solidstart npm
- Intervalos de versiones afectados
- SEMVER: ≥ 10.11.0, < 10.27.0
Actualiza a 10.27.0
@sentry/sveltekit npm
- Intervalos de versiones afectados
- SEMVER: ≥ 10.11.0, < 10.27.0
Actualiza a 10.27.0
Fuentes originales
- https://github.com/getsentry/sentry-javascript/security/advisories/GHSA-6465-jgvq-jhgp
- https://github.com/getsentry/sentry-javascript/pull/17475
- https://github.com/getsentry/sentry-javascript/commit/a820fa2891fdcf985b834a5b557edf351ec54539
- https://github.com/getsentry/sentry-javascript/releases/tag/10.11.0
- https://nvd.nist.gov/vuln/detail/CVE-2025-65944