p PatchFirst

CVE-2025-65944

CVE-2025-65944 · Sentry-Javascript deals with leaked sensitive headers when `sendDefaultPii` is set to `true`

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Sentry-Javascript is an official Sentry SDKs for JavaScript. From version 10.11.0 to before 10.27.0, when a Node.js application using the Sentry SDK has sendDefaultPii: true it is possible to inadvertently send certain sensitive HTTP headers, including the Cookie header, to Sentry. Those headers would be stored within a Sentry organization as part of the associated trace. A person with access to the Sentry organization could then view and use these sensitive values to impersonate or escalate their privileges within the application. This issue has been patched in version 10.27.0.

CVSS 5.1 · Medium · EPSS 0.4% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • sentry-javascript

    Versions
    • >= 10.11.0, < 10.27.0: Affected

    No fix published

  • @sentry/node npm

    Affected ranges
    • SEMVER: ≥ 10.11.0, < 10.27.0

    Update to 10.27.0

  • @sentry/astro npm

    Affected ranges
    • SEMVER: ≥ 10.11.0, < 10.27.0

    Update to 10.27.0

  • @sentry/aws-serverless npm

    Affected ranges
    • SEMVER: ≥ 10.11.0, < 10.27.0

    Update to 10.27.0

  • @sentry/bun npm

    Affected ranges
    • SEMVER: ≥ 10.11.0, < 10.27.0

    Update to 10.27.0

  • @sentry/google-cloud-serverless npm

    Affected ranges
    • SEMVER: ≥ 10.11.0, < 10.27.0

    Update to 10.27.0

  • @sentry/nestjs npm

    Affected ranges
    • SEMVER: ≥ 10.11.0, < 10.27.0

    Update to 10.27.0

  • @sentry/nextjs npm

    Affected ranges
    • SEMVER: ≥ 10.11.0, < 10.27.0

    Update to 10.27.0

  • @sentry/node-core npm

    Affected ranges
    • SEMVER: ≥ 10.11.0, < 10.27.0

    Update to 10.27.0

  • @sentry/nuxt npm

    Affected ranges
    • SEMVER: ≥ 10.11.0, < 10.27.0

    Update to 10.27.0

  • @sentry/remix npm

    Affected ranges
    • SEMVER: ≥ 10.11.0, < 10.27.0

    Update to 10.27.0

  • @sentry/solidstart npm

    Affected ranges
    • SEMVER: ≥ 10.11.0, < 10.27.0

    Update to 10.27.0

  • @sentry/sveltekit npm

    Affected ranges
    • SEMVER: ≥ 10.11.0, < 10.27.0

    Update to 10.27.0

Original sources

Check your server →