CVE-2025-67716
CVE-2025-67716 · Auth0 Next.js SDK has Improper Validation of Query Parameters
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
The Auth0 Next.js SDK is a library for implementing user authentication in Next.js applications. Versions 4.9.0 through 4.12.1 contain an input-validation flaw in the returnTo parameter, which could allow attackers to inject unintended OAuth query parameters into the Auth0 authorization request. Successful exploitation may result in tokens being issued with unintended parameters. This issue is fixed in version 4.13.0.
CVSS 5.7 · Media · EPSS 0,3% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: node
Productos y versiones afectados
nextjs-auth0
- Versiones
- >= 4.9.0, < 4.13.0: Afectada
Sin corrección publicada
@auth0/nextjs-auth0 npm
- Intervalos de versiones afectados
- SEMVER: ≥ 4.9.0, < 4.13.0
Actualiza a 4.13.0