CVE-2025-67716
CVE-2025-67716 · Auth0 Next.js SDK has Improper Validation of Query Parameters
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
The Auth0 Next.js SDK is a library for implementing user authentication in Next.js applications. Versions 4.9.0 through 4.12.1 contain an input-validation flaw in the returnTo parameter, which could allow attackers to inject unintended OAuth query parameters into the Auth0 authorization request. Successful exploitation may result in tokens being issued with unintended parameters. This issue is fixed in version 4.13.0.
CVSS 5.7 · Mittel · EPSS 0,3% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: node
Betroffene Produkte und Versionen
nextjs-auth0
- Softwareversionen
- >= 4.9.0, < 4.13.0: Betroffen
Keine Korrektur veröffentlicht
@auth0/nextjs-auth0 npm
- Betroffene Versionsbereiche
- SEMVER: ≥ 4.9.0, < 4.13.0
Auf 4.13.0 aktualisieren