CVE-2025-67716
CVE-2025-67716 · Auth0 Next.js SDK has Improper Validation of Query Parameters
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
The Auth0 Next.js SDK is a library for implementing user authentication in Next.js applications. Versions 4.9.0 through 4.12.1 contain an input-validation flaw in the returnTo parameter, which could allow attackers to inject unintended OAuth query parameters into the Auth0 authorization request. Successful exploitation may result in tokens being issued with unintended parameters. This issue is fixed in version 4.13.0.
CVSS 5.7 · Moyenne · EPSS 0,3% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: node
Produits et versions concernés
nextjs-auth0
- Versions du logiciel
- >= 4.9.0, < 4.13.0: Concernée
Aucun correctif publié
@auth0/nextjs-auth0 npm
- Plages de versions concernées
- SEMVER: ≥ 4.9.0, < 4.13.0
Mettez à jour vers 4.13.0