p PatchFirst

CVE-2025-69262

CVE-2025-69262 · pnpm vulnerable to Command Injection via environment variable substitution

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

pnpm is a package manager. Versions 6.25.0 through 10.26.2 have a Command Injection vulnerability when using environment variable substitution in .npmrc configuration files with tokenHelper settings. An attacker who can control environment variables during pnpm operations could achieve Remote Code Execution (RCE) in build environments. This issue is fixed in version 10.27.0.

CVSS 7.6 · Alta · EPSS 1,0% · Corrección disponible

Publicación
Actualización

Pila tecnológica: node

Productos y versiones afectados

  • pnpm

    Versiones
    • >=6.25.0, < 10.27.0: Afectada

    Sin corrección publicada

  • pnpm npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 6.25.0, < 10.27.0

    Actualiza a 10.27.0

Fuentes originales

Comprueba tu servidor →