p PatchFirst

CVE-2025-69262

CVE-2025-69262 · pnpm vulnerable to Command Injection via environment variable substitution

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

pnpm is a package manager. Versions 6.25.0 through 10.26.2 have a Command Injection vulnerability when using environment variable substitution in .npmrc configuration files with tokenHelper settings. An attacker who can control environment variables during pnpm operations could achieve Remote Code Execution (RCE) in build environments. This issue is fixed in version 10.27.0.

CVSS 7.6 · Hoch · EPSS 1,0% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: node

Betroffene Produkte und Versionen

  • pnpm

    Softwareversionen
    • >=6.25.0, < 10.27.0: Betroffen

    Keine Korrektur veröffentlicht

  • pnpm npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 6.25.0, < 10.27.0

    Auf 10.27.0 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →