p PatchFirst

CVE-2025-69262

CVE-2025-69262 · pnpm vulnerable to Command Injection via environment variable substitution

This page contains facts from public vulnerability sources. Check the original advisory before updating.

pnpm is a package manager. Versions 6.25.0 through 10.26.2 have a Command Injection vulnerability when using environment variable substitution in .npmrc configuration files with tokenHelper settings. An attacker who can control environment variables during pnpm operations could achieve Remote Code Execution (RCE) in build environments. This issue is fixed in version 10.27.0.

CVSS 7.6 · High · EPSS 1.0% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • pnpm

    Versions
    • >=6.25.0, < 10.27.0: Affected

    No fix published

  • pnpm npm

    Affected ranges
    • SEMVER: ≥ 6.25.0, < 10.27.0

    Update to 10.27.0

Original sources

Check your server →