p PatchFirst

CVE-2026-102274

CVE-2026-102274 · PyJWT: Malformed RSA JWK aborts parsing of an entire JWK Set

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

PyJWT is a Python implementation of JSON Web Token standards. From 2.9.0 until 2.14.0, PyJWKSet does not catch the plain ValueError raised for malformed RSA JWK components by RSAAlgorithm.from_jwk in jwt/api_jwk.py. This occurs when a JWK Set contains a malformed RSA key alongside otherwise usable keys. As a result, one malformed member aborts construction of the entire PyJWKSet. Consequently, applications can experience authentication failures or request-level denial of service. This issue is fixed in version 2.14.0.

CVSS 5.9 · Media · EPSS 0,5% · Código de explotación público · Corrección disponible

Publicación
Actualización

Pila tecnológica: system · python

Productos y versiones afectados

  • pyjwt

    Versiones
    • >= 2.9.0, < 2.14.0: Afectada

    Sin corrección publicada

  • pyjwt Debian:12

    Versiones
    • 2.10.1-1
    • 2.10.1-2
    • 2.10.1-3
    • 2.10.1-4
    • 2.11.0-2
    • 2.12.1-1
    • 2.13.0-1
    • 2.14.0-1
    • 2.15.0-1
    • 2.15.1-1
    • 2.6.0-1
    • 2.6.0-1+deb12u1
    • 2.7.0-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • pyjwt Debian:13

    Versiones
    • 2.10.1-2
    • 2.10.1-2+deb13u1
    • 2.10.1-3
    • 2.10.1-4
    • 2.11.0-2
    • 2.12.1-1
    • 2.13.0-1
    • 2.14.0-1
    • 2.15.0-1
    • 2.15.1-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • pyjwt Debian:14

    Versiones
    • 2.10.1-2
    • 2.10.1-3
    • 2.10.1-4
    • 2.11.0-2
    • 2.12.1-1
    • 2.13.0-1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.14.0-1

    Actualiza a 2.14.0-1

  • pyjwt PyPI

    Versiones
    • 2.10.0
    • 2.10.1
    • 2.11.0
    • 2.12.0
    • 2.12.1
    • 2.13.0
    • 2.9.0
    Intervalos de versiones afectados
    • ECOSYSTEM: ≥ 2.9.0, < 2.14.0

    Actualiza a 2.14.0

  • pyjwt Ubuntu:22.04:LTS

    Versiones
    • 1.7.1-2ubuntu2
    • 2.1.0-1
    • 2.3.0-1
    • 2.3.0-1ubuntu0.1
    • 2.3.0-1ubuntu0.2
    • 2.3.0-1ubuntu0.3
    • 2.3.0-1ubuntu0.4
    • 2.3.0-1ubuntu0.5
    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.3.0-1ubuntu0.6

    Actualiza a 2.3.0-1ubuntu0.6

  • pyjwt Ubuntu:24.04:LTS

    Versiones
    • 2.7.0-1
    • 2.7.0-1ubuntu0.1
    • 2.7.0-1ubuntu0.2
    • 2.7.0-1ubuntu0.3
    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.7.0-1ubuntu0.4

    Actualiza a 2.7.0-1ubuntu0.4

  • pyjwt Ubuntu:26.10

    Versiones
    • 2.10.1-4ubuntu1
    • 2.12.1-1
    • 2.13.0-1
    • 2.13.0-1ubuntu1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.13.0-1ubuntu1.1

    Actualiza a 2.13.0-1ubuntu1.1

  • pyjwt Ubuntu:26.04:LTS

    Versiones
    • 2.10.1-2
    • 2.10.1-3
    • 2.10.1-3build1
    • 2.10.1-4
    • 2.10.1-4ubuntu1
    • 2.10.1-4ubuntu1.1
    • 2.10.1-4ubuntu1.2
    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.10.1-4ubuntu1.3

    Actualiza a 2.10.1-4ubuntu1.3

Fuentes originales

Comprueba tu servidor →