CVE-2026-102274
CVE-2026-102274 · PyJWT: Malformed RSA JWK aborts parsing of an entire JWK Set
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
PyJWT is a Python implementation of JSON Web Token standards. From 2.9.0 until 2.14.0, PyJWKSet does not catch the plain ValueError raised for malformed RSA JWK components by RSAAlgorithm.from_jwk in jwt/api_jwk.py. This occurs when a JWK Set contains a malformed RSA key alongside otherwise usable keys. As a result, one malformed member aborts construction of the entire PyJWKSet. Consequently, applications can experience authentication failures or request-level denial of service. This issue is fixed in version 2.14.0.
CVSS 5.9 · Mittel · EPSS 0,5% · Öffentlicher Exploit · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system · python
Betroffene Produkte und Versionen
pyjwt
- Softwareversionen
- >= 2.9.0, < 2.14.0: Betroffen
Keine Korrektur veröffentlicht
pyjwt Debian:12
- Softwareversionen
- 2.10.1-1
- 2.10.1-2
- 2.10.1-3
- 2.10.1-4
- 2.11.0-2
- 2.12.1-1
- 2.13.0-1
- 2.14.0-1
- 2.15.0-1
- 2.15.1-1
- 2.6.0-1
- 2.6.0-1+deb12u1
- 2.7.0-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
pyjwt Debian:13
- Softwareversionen
- 2.10.1-2
- 2.10.1-2+deb13u1
- 2.10.1-3
- 2.10.1-4
- 2.11.0-2
- 2.12.1-1
- 2.13.0-1
- 2.14.0-1
- 2.15.0-1
- 2.15.1-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
pyjwt Debian:14
- Softwareversionen
- 2.10.1-2
- 2.10.1-3
- 2.10.1-4
- 2.11.0-2
- 2.12.1-1
- 2.13.0-1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.14.0-1
Auf 2.14.0-1 aktualisieren
pyjwt PyPI
- Softwareversionen
- 2.10.0
- 2.10.1
- 2.11.0
- 2.12.0
- 2.12.1
- 2.13.0
- 2.9.0
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 2.9.0, < 2.14.0
Auf 2.14.0 aktualisieren
pyjwt Ubuntu:22.04:LTS
- Softwareversionen
- 1.7.1-2ubuntu2
- 2.1.0-1
- 2.3.0-1
- 2.3.0-1ubuntu0.1
- 2.3.0-1ubuntu0.2
- 2.3.0-1ubuntu0.3
- 2.3.0-1ubuntu0.4
- 2.3.0-1ubuntu0.5
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.3.0-1ubuntu0.6
Auf 2.3.0-1ubuntu0.6 aktualisieren
pyjwt Ubuntu:24.04:LTS
- Softwareversionen
- 2.7.0-1
- 2.7.0-1ubuntu0.1
- 2.7.0-1ubuntu0.2
- 2.7.0-1ubuntu0.3
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.7.0-1ubuntu0.4
Auf 2.7.0-1ubuntu0.4 aktualisieren
pyjwt Ubuntu:26.10
- Softwareversionen
- 2.10.1-4ubuntu1
- 2.12.1-1
- 2.13.0-1
- 2.13.0-1ubuntu1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.13.0-1ubuntu1.1
Auf 2.13.0-1ubuntu1.1 aktualisieren
pyjwt Ubuntu:26.04:LTS
- Softwareversionen
- 2.10.1-2
- 2.10.1-3
- 2.10.1-3build1
- 2.10.1-4
- 2.10.1-4ubuntu1
- 2.10.1-4ubuntu1.1
- 2.10.1-4ubuntu1.2
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.10.1-4ubuntu1.3
Auf 2.10.1-4ubuntu1.3 aktualisieren