CVE-2026-102274
CVE-2026-102274 · PyJWT: Malformed RSA JWK aborts parsing of an entire JWK Set
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
PyJWT is a Python implementation of JSON Web Token standards. From 2.9.0 until 2.14.0, PyJWKSet does not catch the plain ValueError raised for malformed RSA JWK components by RSAAlgorithm.from_jwk in jwt/api_jwk.py. This occurs when a JWK Set contains a malformed RSA key alongside otherwise usable keys. As a result, one malformed member aborts construction of the entire PyJWKSet. Consequently, applications can experience authentication failures or request-level denial of service. This issue is fixed in version 2.14.0.
CVSS 5.9 · Moyenne · EPSS 0,5% · Code d’exploitation public · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system · python
Produits et versions concernés
pyjwt
- Versions du logiciel
- >= 2.9.0, < 2.14.0: Concernée
Aucun correctif publié
pyjwt Debian:12
- Versions du logiciel
- 2.10.1-1
- 2.10.1-2
- 2.10.1-3
- 2.10.1-4
- 2.11.0-2
- 2.12.1-1
- 2.13.0-1
- 2.14.0-1
- 2.15.0-1
- 2.15.1-1
- 2.6.0-1
- 2.6.0-1+deb12u1
- 2.7.0-1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
pyjwt Debian:13
- Versions du logiciel
- 2.10.1-2
- 2.10.1-2+deb13u1
- 2.10.1-3
- 2.10.1-4
- 2.11.0-2
- 2.12.1-1
- 2.13.0-1
- 2.14.0-1
- 2.15.0-1
- 2.15.1-1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
pyjwt Debian:14
- Versions du logiciel
- 2.10.1-2
- 2.10.1-3
- 2.10.1-4
- 2.11.0-2
- 2.12.1-1
- 2.13.0-1
- Plages de versions concernées
- ECOSYSTEM: < 2.14.0-1
Mettez à jour vers 2.14.0-1
pyjwt PyPI
- Versions du logiciel
- 2.10.0
- 2.10.1
- 2.11.0
- 2.12.0
- 2.12.1
- 2.13.0
- 2.9.0
- Plages de versions concernées
- ECOSYSTEM: ≥ 2.9.0, < 2.14.0
Mettez à jour vers 2.14.0
pyjwt Ubuntu:22.04:LTS
- Versions du logiciel
- 1.7.1-2ubuntu2
- 2.1.0-1
- 2.3.0-1
- 2.3.0-1ubuntu0.1
- 2.3.0-1ubuntu0.2
- 2.3.0-1ubuntu0.3
- 2.3.0-1ubuntu0.4
- 2.3.0-1ubuntu0.5
- Plages de versions concernées
- ECOSYSTEM: < 2.3.0-1ubuntu0.6
Mettez à jour vers 2.3.0-1ubuntu0.6
pyjwt Ubuntu:24.04:LTS
- Versions du logiciel
- 2.7.0-1
- 2.7.0-1ubuntu0.1
- 2.7.0-1ubuntu0.2
- 2.7.0-1ubuntu0.3
- Plages de versions concernées
- ECOSYSTEM: < 2.7.0-1ubuntu0.4
Mettez à jour vers 2.7.0-1ubuntu0.4
pyjwt Ubuntu:26.10
- Versions du logiciel
- 2.10.1-4ubuntu1
- 2.12.1-1
- 2.13.0-1
- 2.13.0-1ubuntu1
- Plages de versions concernées
- ECOSYSTEM: < 2.13.0-1ubuntu1.1
Mettez à jour vers 2.13.0-1ubuntu1.1
pyjwt Ubuntu:26.04:LTS
- Versions du logiciel
- 2.10.1-2
- 2.10.1-3
- 2.10.1-3build1
- 2.10.1-4
- 2.10.1-4ubuntu1
- 2.10.1-4ubuntu1.1
- 2.10.1-4ubuntu1.2
- Plages de versions concernées
- ECOSYSTEM: < 2.10.1-4ubuntu1.3
Mettez à jour vers 2.10.1-4ubuntu1.3