p PatchFirst

CVE-2026-112944

CVE-2026-112944 · launch-editor: Editor CLI flag misinterpretation causing arbitrary command execution for some editors

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

launch-editor allows users to open files with line numbers in editor from Node.js. Prior to 2.14.2, when an attacker can create a filesystem entry beginning with plus or minus in the working directory, an affected editor is selected, and the path can remain relative or is converted to a relative WSL path, launchEditor forwards the path without forcing it to be interpreted as a positional filename. Editor option parsing then treats the attacker-controlled filename as a command-line flag, which can cause unintended file overwrite or arbitrary command execution by the selected editor. The affected editors are Vim and gVim, MacVim, Emacs and Emacsclient, and Notepad++ when a plugin exposes dangerous operations; WSL path conversion keeps Vite and newer middleware callers exposed. This issue is fixed in version 2.14.2.

CVSS 6.3 · Media · EPSS 0,7% · Corrección disponible

Publicación
Actualización

Pila tecnológica: node

Productos y versiones afectados

  • launch-editor

    Versiones
    • < 2.14.2: Afectada

    Sin corrección publicada

  • vite

    Versiones
    • >= 8.3.0, < 8.3.3: Afectada
    • >= 8.2.0, < 8.2.4: Afectada
    • >= 8.0.0, < 8.1.6: Afectada
    • >= 7.0.0, < 7.3.7: Afectada
    • < 6.4.4: Afectada

    Sin corrección publicada

  • vite-plus

    Versiones
    • < 1.1.0: Afectada

    Sin corrección publicada

  • launch-editor npm

    Intervalos de versiones afectados
    • SEMVER: < 2.14.2

    Actualiza a 2.14.2

  • vite npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 8.3.0, < 8.3.3

    Actualiza a 8.3.3

  • vite npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 8.2.0, < 8.2.4

    Actualiza a 8.2.4

  • vite npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 8.0.0, < 8.1.6

    Actualiza a 8.1.6

  • vite npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 7.0.0, < 7.3.7

    Actualiza a 7.3.7

  • vite npm

    Intervalos de versiones afectados
    • SEMVER: < 6.4.4

    Actualiza a 6.4.4

  • vite-plus npm

    Intervalos de versiones afectados
    • SEMVER: < 1.1.0

    Actualiza a 1.1.0

Fuentes originales

Comprueba tu servidor →