p PatchFirst

CVE-2026-112944

CVE-2026-112944 · launch-editor: Editor CLI flag misinterpretation causing arbitrary command execution for some editors

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

launch-editor allows users to open files with line numbers in editor from Node.js. Prior to 2.14.2, when an attacker can create a filesystem entry beginning with plus or minus in the working directory, an affected editor is selected, and the path can remain relative or is converted to a relative WSL path, launchEditor forwards the path without forcing it to be interpreted as a positional filename. Editor option parsing then treats the attacker-controlled filename as a command-line flag, which can cause unintended file overwrite or arbitrary command execution by the selected editor. The affected editors are Vim and gVim, MacVim, Emacs and Emacsclient, and Notepad++ when a plugin exposes dangerous operations; WSL path conversion keeps Vite and newer middleware callers exposed. This issue is fixed in version 2.14.2.

CVSS 6.3 · Moyenne · EPSS 0,7% · Correctif disponible

Publication
Mise à jour

Pile logicielle: node

Produits et versions concernés

  • launch-editor

    Versions du logiciel
    • < 2.14.2: Concernée

    Aucun correctif publié

  • vite

    Versions du logiciel
    • >= 8.3.0, < 8.3.3: Concernée
    • >= 8.2.0, < 8.2.4: Concernée
    • >= 8.0.0, < 8.1.6: Concernée
    • >= 7.0.0, < 7.3.7: Concernée
    • < 6.4.4: Concernée

    Aucun correctif publié

  • vite-plus

    Versions du logiciel
    • < 1.1.0: Concernée

    Aucun correctif publié

  • launch-editor npm

    Plages de versions concernées
    • SEMVER: < 2.14.2

    Mettez à jour vers 2.14.2

  • vite npm

    Plages de versions concernées
    • SEMVER: ≥ 8.3.0, < 8.3.3

    Mettez à jour vers 8.3.3

  • vite npm

    Plages de versions concernées
    • SEMVER: ≥ 8.2.0, < 8.2.4

    Mettez à jour vers 8.2.4

  • vite npm

    Plages de versions concernées
    • SEMVER: ≥ 8.0.0, < 8.1.6

    Mettez à jour vers 8.1.6

  • vite npm

    Plages de versions concernées
    • SEMVER: ≥ 7.0.0, < 7.3.7

    Mettez à jour vers 7.3.7

  • vite npm

    Plages de versions concernées
    • SEMVER: < 6.4.4

    Mettez à jour vers 6.4.4

  • vite-plus npm

    Plages de versions concernées
    • SEMVER: < 1.1.0

    Mettez à jour vers 1.1.0

Sources originales

Vérifiez votre serveur →