p PatchFirst

CVE-2026-112944

CVE-2026-112944 · launch-editor: Editor CLI flag misinterpretation causing arbitrary command execution for some editors

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

launch-editor allows users to open files with line numbers in editor from Node.js. Prior to 2.14.2, when an attacker can create a filesystem entry beginning with plus or minus in the working directory, an affected editor is selected, and the path can remain relative or is converted to a relative WSL path, launchEditor forwards the path without forcing it to be interpreted as a positional filename. Editor option parsing then treats the attacker-controlled filename as a command-line flag, which can cause unintended file overwrite or arbitrary command execution by the selected editor. The affected editors are Vim and gVim, MacVim, Emacs and Emacsclient, and Notepad++ when a plugin exposes dangerous operations; WSL path conversion keeps Vite and newer middleware callers exposed. This issue is fixed in version 2.14.2.

CVSS 6.3 · Mittel · EPSS 0,7% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: node

Betroffene Produkte und Versionen

  • launch-editor

    Softwareversionen
    • < 2.14.2: Betroffen

    Keine Korrektur veröffentlicht

  • vite

    Softwareversionen
    • >= 8.3.0, < 8.3.3: Betroffen
    • >= 8.2.0, < 8.2.4: Betroffen
    • >= 8.0.0, < 8.1.6: Betroffen
    • >= 7.0.0, < 7.3.7: Betroffen
    • < 6.4.4: Betroffen

    Keine Korrektur veröffentlicht

  • vite-plus

    Softwareversionen
    • < 1.1.0: Betroffen

    Keine Korrektur veröffentlicht

  • launch-editor npm

    Betroffene Versionsbereiche
    • SEMVER: < 2.14.2

    Auf 2.14.2 aktualisieren

  • vite npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 8.3.0, < 8.3.3

    Auf 8.3.3 aktualisieren

  • vite npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 8.2.0, < 8.2.4

    Auf 8.2.4 aktualisieren

  • vite npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 8.0.0, < 8.1.6

    Auf 8.1.6 aktualisieren

  • vite npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 7.0.0, < 7.3.7

    Auf 7.3.7 aktualisieren

  • vite npm

    Betroffene Versionsbereiche
    • SEMVER: < 6.4.4

    Auf 6.4.4 aktualisieren

  • vite-plus npm

    Betroffene Versionsbereiche
    • SEMVER: < 1.1.0

    Auf 1.1.0 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →