p PatchFirst

CVE-2026-15529

CVE-2026-15529 · yzhao062 pyod persistence.py pyod.utils.persistence.load deserialization

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

A vulnerability was detected in yzhao062 pyod up to 3.6.1. Affected is the function pyod.utils.persistence.load of the file pyod/utils/persistence.py. Performing a manipulation of the argument path results in deserialization. The attack can be initiated remotely. Upgrading to version 3.6.2 is able to address this issue. It is recommended to apply a patch to fix this issue. The pull request to fix this issue requires some minor changes.

CVSS 5.3 · Media · EPSS 0,4% · Corrección disponible

Publicación
Actualización

Pila tecnológica: python

Productos y versiones afectados

  • pyod

    Versiones
    • 3.5.0: Afectada
    • 3.5.1: Afectada
    • 3.5.2: Afectada
    • 3.5.4: Afectada
    • 3.6.0: Afectada
    • 3.6.1: Afectada
    • 3.6.2: No afectada

    Actualiza a 3.6.2

  • pyod PyPI

    Versiones
    • 3.5.0
    • 3.5.1
    • 3.5.2
    • 3.5.4
    • 3.6.0
    • 3.6.1
    Intervalos de versiones afectados
    • ECOSYSTEM: ≥ 3.5.0, < 3.6.2

    Actualiza a 3.6.2

Fuentes originales

Comprueba tu servidor →