p PatchFirst

CVE-2026-15529

CVE-2026-15529 · yzhao062 pyod persistence.py pyod.utils.persistence.load deserialization

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

A vulnerability was detected in yzhao062 pyod up to 3.6.1. Affected is the function pyod.utils.persistence.load of the file pyod/utils/persistence.py. Performing a manipulation of the argument path results in deserialization. The attack can be initiated remotely. Upgrading to version 3.6.2 is able to address this issue. It is recommended to apply a patch to fix this issue. The pull request to fix this issue requires some minor changes.

CVSS 5.3 · Mittel · EPSS 0,4% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: python

Betroffene Produkte und Versionen

  • pyod

    Softwareversionen
    • 3.5.0: Betroffen
    • 3.5.1: Betroffen
    • 3.5.2: Betroffen
    • 3.5.4: Betroffen
    • 3.6.0: Betroffen
    • 3.6.1: Betroffen
    • 3.6.2: Nicht betroffen

    Auf 3.6.2 aktualisieren

  • pyod PyPI

    Softwareversionen
    • 3.5.0
    • 3.5.1
    • 3.5.2
    • 3.5.4
    • 3.6.0
    • 3.6.1
    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 3.5.0, < 3.6.2

    Auf 3.6.2 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →