p PatchFirst

CVE-2026-15529

CVE-2026-15529 · yzhao062 pyod persistence.py pyod.utils.persistence.load deserialization

This page contains facts from public vulnerability sources. Check the original advisory before updating.

A vulnerability was detected in yzhao062 pyod up to 3.6.1. Affected is the function pyod.utils.persistence.load of the file pyod/utils/persistence.py. Performing a manipulation of the argument path results in deserialization. The attack can be initiated remotely. Upgrading to version 3.6.2 is able to address this issue. It is recommended to apply a patch to fix this issue. The pull request to fix this issue requires some minor changes.

CVSS 5.3 · Medium · EPSS 0.4% · Fix available

Published
Updated

Stack: python

Affected products and versions

  • pyod

    Versions
    • 3.5.0: Affected
    • 3.5.1: Affected
    • 3.5.2: Affected
    • 3.5.4: Affected
    • 3.6.0: Affected
    • 3.6.1: Affected
    • 3.6.2: Not affected

    Update to 3.6.2

  • pyod PyPI

    Versions
    • 3.5.0
    • 3.5.1
    • 3.5.2
    • 3.5.4
    • 3.6.0
    • 3.6.1
    Affected ranges
    • ECOSYSTEM: ≥ 3.5.0, < 3.6.2

    Update to 3.6.2

Original sources

Check your server →