p PatchFirst

CVE-2026-18446

CVE-2026-18446 · fast-uri vulnerable to host confusion via backslash authority introducer

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

fast-uri before 4.1.2, 3.1.5, and 2.4.4 requires a literal double forward slash to recognize a URI authority, so a reference that uses a backslash based introducer in place of it (backslash backslash, forward slash backslash, or backslash forward slash) is parsed with no authority and folds into the path. Node's native WHATWG URL parser instead treats a backslash as interchangeable with a forward slash for special schemes, so the two parsers extract different hosts from the same input. Applications that use fast-uri to enforce host based policy such as allowlists, SSRF filtering, or redirect validation before passing the same URL into Node's URL or fetch consumers can be steered to an unintended host. Upgrade to fast-uri 4.1.2, 3.1.5, or 2.4.4.

CVSS 7.5 · Alta · EPSS 0,4% · Corrección disponible

Publicación
Actualización

Pila tecnológica: system · node

Productos y versiones afectados

  • fast-uri

    Versiones
    • ≥ 4.0.0, < 4.1.2: Afectada (semver)
    • 4.1.2: No afectada (semver)
    • ≥ 3.0.0, < 3.1.5: Afectada (semver)
    • 3.1.5: No afectada (semver)
    • ≥ 0, < 2.4.4: Afectada (semver)
    • 2.4.4: No afectada (semver)

    Actualiza a 2.4.4; Actualiza a 3.1.5; Actualiza a 4.1.2

  • node-ajv Debian:13

    Versiones
    • 8.12.0~ds+~2.1.1-5
    • 8.17.1~ds+~3.0.1+~3.1.0-1
    • 8.17.1~ds+~3.0.1+~3.1.0-2
    • 8.17.1~ds+~3.0.1+~3.1.0-3
    • 8.17.1~ds+~3.0.1+~3.1.0-4
    • 8.18.0~ds+~cs6.1.1-1
    • 8.18.0~ds+~cs6.1.1-2
    • 8.20.0~ds+~cs6.1.3-1
    • 8.20.0~ds+~cs7.1.2-1
    • 8.20.0~ds+~cs7.1.3-1
    • 8.20.0~ds+~cs7.1.3-2
    • 8.20.0~ds+~cs7.1.3-3
    • 8.20.0~ds+~cs7.1.4-1
    • 8.20.0~ds+~cs7.1.5-1
    • 8.20.0~ds+~cs7.1.6-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-ajv Debian:14

    Versiones
    • 8.12.0~ds+~2.1.1-5
    • 8.17.1~ds+~3.0.1+~3.1.0-1
    • 8.17.1~ds+~3.0.1+~3.1.0-2
    • 8.17.1~ds+~3.0.1+~3.1.0-3
    • 8.17.1~ds+~3.0.1+~3.1.0-4
    • 8.18.0~ds+~cs6.1.1-1
    • 8.18.0~ds+~cs6.1.1-2
    • 8.20.0~ds+~cs6.1.3-1
    • 8.20.0~ds+~cs7.1.2-1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 8.20.0~ds+~cs7.1.3-1

    Actualiza a 8.20.0~ds+~cs7.1.3-1

  • fast-uri npm

    Intervalos de versiones afectados
    • SEMVER: < 2.4.4

    Actualiza a 2.4.4

  • fast-uri npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 3.0.0, < 3.1.5

    Actualiza a 3.1.5

  • fast-uri npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 4.0.0, < 4.1.2

    Actualiza a 4.1.2

  • node-ajv Ubuntu:18.04:LTS

    Versiones
    • 5.0.0-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-ajv Ubuntu:20.04:LTS

    Versiones
    • 6.10.2-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-ajv Ubuntu:22.04:LTS

    Versiones
    • 6.12.6-2
    • 6.12.6-3
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-ajv Ubuntu:24.04:LTS

    Versiones
    • 6.12.6-3
    • 8.12.0~ds+~2.1.1-4
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-ajv Ubuntu:26.10

    Versiones
    • 8.17.1~ds+~3.0.1+~3.1.0-4build1
    • 8.20.0~ds+~cs6.1.3-1
    • 8.20.0~ds+~cs7.1.2-1
    • 8.20.0~ds+~cs7.1.3-1
    • 8.20.0~ds+~cs7.1.3-3
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-ajv Ubuntu:26.04:LTS

    Versiones
    • 8.12.0~ds+~2.1.1-5
    • 8.17.1~ds+~3.0.1+~3.1.0-2
    • 8.17.1~ds+~3.0.1+~3.1.0-4build1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

Fuentes originales

Comprueba tu servidor →