p PatchFirst

CVE-2026-18446

CVE-2026-18446 · fast-uri vulnerable to host confusion via backslash authority introducer

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

fast-uri before 4.1.2, 3.1.5, and 2.4.4 requires a literal double forward slash to recognize a URI authority, so a reference that uses a backslash based introducer in place of it (backslash backslash, forward slash backslash, or backslash forward slash) is parsed with no authority and folds into the path. Node's native WHATWG URL parser instead treats a backslash as interchangeable with a forward slash for special schemes, so the two parsers extract different hosts from the same input. Applications that use fast-uri to enforce host based policy such as allowlists, SSRF filtering, or redirect validation before passing the same URL into Node's URL or fetch consumers can be steered to an unintended host. Upgrade to fast-uri 4.1.2, 3.1.5, or 2.4.4.

CVSS 7.5 · Hoch · EPSS 0,4% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system · node

Betroffene Produkte und Versionen

  • fast-uri

    Softwareversionen
    • ≥ 4.0.0, < 4.1.2: Betroffen (semver)
    • 4.1.2: Nicht betroffen (semver)
    • ≥ 3.0.0, < 3.1.5: Betroffen (semver)
    • 3.1.5: Nicht betroffen (semver)
    • ≥ 0, < 2.4.4: Betroffen (semver)
    • 2.4.4: Nicht betroffen (semver)

    Auf 2.4.4 aktualisieren; Auf 3.1.5 aktualisieren; Auf 4.1.2 aktualisieren

  • node-ajv Debian:13

    Softwareversionen
    • 8.12.0~ds+~2.1.1-5
    • 8.17.1~ds+~3.0.1+~3.1.0-1
    • 8.17.1~ds+~3.0.1+~3.1.0-2
    • 8.17.1~ds+~3.0.1+~3.1.0-3
    • 8.17.1~ds+~3.0.1+~3.1.0-4
    • 8.18.0~ds+~cs6.1.1-1
    • 8.18.0~ds+~cs6.1.1-2
    • 8.20.0~ds+~cs6.1.3-1
    • 8.20.0~ds+~cs7.1.2-1
    • 8.20.0~ds+~cs7.1.3-1
    • 8.20.0~ds+~cs7.1.3-2
    • 8.20.0~ds+~cs7.1.3-3
    • 8.20.0~ds+~cs7.1.4-1
    • 8.20.0~ds+~cs7.1.5-1
    • 8.20.0~ds+~cs7.1.6-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-ajv Debian:14

    Softwareversionen
    • 8.12.0~ds+~2.1.1-5
    • 8.17.1~ds+~3.0.1+~3.1.0-1
    • 8.17.1~ds+~3.0.1+~3.1.0-2
    • 8.17.1~ds+~3.0.1+~3.1.0-3
    • 8.17.1~ds+~3.0.1+~3.1.0-4
    • 8.18.0~ds+~cs6.1.1-1
    • 8.18.0~ds+~cs6.1.1-2
    • 8.20.0~ds+~cs6.1.3-1
    • 8.20.0~ds+~cs7.1.2-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 8.20.0~ds+~cs7.1.3-1

    Auf 8.20.0~ds+~cs7.1.3-1 aktualisieren

  • fast-uri npm

    Betroffene Versionsbereiche
    • SEMVER: < 2.4.4

    Auf 2.4.4 aktualisieren

  • fast-uri npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 3.0.0, < 3.1.5

    Auf 3.1.5 aktualisieren

  • fast-uri npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 4.0.0, < 4.1.2

    Auf 4.1.2 aktualisieren

  • node-ajv Ubuntu:18.04:LTS

    Softwareversionen
    • 5.0.0-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-ajv Ubuntu:20.04:LTS

    Softwareversionen
    • 6.10.2-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-ajv Ubuntu:22.04:LTS

    Softwareversionen
    • 6.12.6-2
    • 6.12.6-3
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-ajv Ubuntu:24.04:LTS

    Softwareversionen
    • 6.12.6-3
    • 8.12.0~ds+~2.1.1-4
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-ajv Ubuntu:26.10

    Softwareversionen
    • 8.17.1~ds+~3.0.1+~3.1.0-4build1
    • 8.20.0~ds+~cs6.1.3-1
    • 8.20.0~ds+~cs7.1.2-1
    • 8.20.0~ds+~cs7.1.3-1
    • 8.20.0~ds+~cs7.1.3-3
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-ajv Ubuntu:26.04:LTS

    Softwareversionen
    • 8.12.0~ds+~2.1.1-5
    • 8.17.1~ds+~3.0.1+~3.1.0-2
    • 8.17.1~ds+~3.0.1+~3.1.0-4build1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →