p PatchFirst

CVE-2026-18446

CVE-2026-18446 · fast-uri vulnerable to host confusion via backslash authority introducer

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

fast-uri before 4.1.2, 3.1.5, and 2.4.4 requires a literal double forward slash to recognize a URI authority, so a reference that uses a backslash based introducer in place of it (backslash backslash, forward slash backslash, or backslash forward slash) is parsed with no authority and folds into the path. Node's native WHATWG URL parser instead treats a backslash as interchangeable with a forward slash for special schemes, so the two parsers extract different hosts from the same input. Applications that use fast-uri to enforce host based policy such as allowlists, SSRF filtering, or redirect validation before passing the same URL into Node's URL or fetch consumers can be steered to an unintended host. Upgrade to fast-uri 4.1.2, 3.1.5, or 2.4.4.

CVSS 7.5 · Élevée · EPSS 0,4% · Correctif disponible

Publication
Mise à jour

Pile logicielle: system · node

Produits et versions concernés

  • fast-uri

    Versions du logiciel
    • ≥ 4.0.0, < 4.1.2: Concernée (semver)
    • 4.1.2: Non concernée (semver)
    • ≥ 3.0.0, < 3.1.5: Concernée (semver)
    • 3.1.5: Non concernée (semver)
    • ≥ 0, < 2.4.4: Concernée (semver)
    • 2.4.4: Non concernée (semver)

    Mettez à jour vers 2.4.4; Mettez à jour vers 3.1.5; Mettez à jour vers 4.1.2

  • node-ajv Debian:13

    Versions du logiciel
    • 8.12.0~ds+~2.1.1-5
    • 8.17.1~ds+~3.0.1+~3.1.0-1
    • 8.17.1~ds+~3.0.1+~3.1.0-2
    • 8.17.1~ds+~3.0.1+~3.1.0-3
    • 8.17.1~ds+~3.0.1+~3.1.0-4
    • 8.18.0~ds+~cs6.1.1-1
    • 8.18.0~ds+~cs6.1.1-2
    • 8.20.0~ds+~cs6.1.3-1
    • 8.20.0~ds+~cs7.1.2-1
    • 8.20.0~ds+~cs7.1.3-1
    • 8.20.0~ds+~cs7.1.3-2
    • 8.20.0~ds+~cs7.1.3-3
    • 8.20.0~ds+~cs7.1.4-1
    • 8.20.0~ds+~cs7.1.5-1
    • 8.20.0~ds+~cs7.1.6-1
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • node-ajv Debian:14

    Versions du logiciel
    • 8.12.0~ds+~2.1.1-5
    • 8.17.1~ds+~3.0.1+~3.1.0-1
    • 8.17.1~ds+~3.0.1+~3.1.0-2
    • 8.17.1~ds+~3.0.1+~3.1.0-3
    • 8.17.1~ds+~3.0.1+~3.1.0-4
    • 8.18.0~ds+~cs6.1.1-1
    • 8.18.0~ds+~cs6.1.1-2
    • 8.20.0~ds+~cs6.1.3-1
    • 8.20.0~ds+~cs7.1.2-1
    Plages de versions concernées
    • ECOSYSTEM: < 8.20.0~ds+~cs7.1.3-1

    Mettez à jour vers 8.20.0~ds+~cs7.1.3-1

  • fast-uri npm

    Plages de versions concernées
    • SEMVER: < 2.4.4

    Mettez à jour vers 2.4.4

  • fast-uri npm

    Plages de versions concernées
    • SEMVER: ≥ 3.0.0, < 3.1.5

    Mettez à jour vers 3.1.5

  • fast-uri npm

    Plages de versions concernées
    • SEMVER: ≥ 4.0.0, < 4.1.2

    Mettez à jour vers 4.1.2

  • node-ajv Ubuntu:18.04:LTS

    Versions du logiciel
    • 5.0.0-1
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • node-ajv Ubuntu:20.04:LTS

    Versions du logiciel
    • 6.10.2-1
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • node-ajv Ubuntu:22.04:LTS

    Versions du logiciel
    • 6.12.6-2
    • 6.12.6-3
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • node-ajv Ubuntu:24.04:LTS

    Versions du logiciel
    • 6.12.6-3
    • 8.12.0~ds+~2.1.1-4
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • node-ajv Ubuntu:26.10

    Versions du logiciel
    • 8.17.1~ds+~3.0.1+~3.1.0-4build1
    • 8.20.0~ds+~cs6.1.3-1
    • 8.20.0~ds+~cs7.1.2-1
    • 8.20.0~ds+~cs7.1.3-1
    • 8.20.0~ds+~cs7.1.3-3
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • node-ajv Ubuntu:26.04:LTS

    Versions du logiciel
    • 8.12.0~ds+~2.1.1-5
    • 8.17.1~ds+~3.0.1+~3.1.0-2
    • 8.17.1~ds+~3.0.1+~3.1.0-4build1
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

Sources originales

Vérifiez votre serveur →