p PatchFirst

CVE-2026-26974

CVE-2026-26974 · Sylde has Improper Control of Generation of Code

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

Slyde is a program that creates animated presentations from XML. In versions 0.0.4 and below, Node.js automatically imports **/*.plugin.{js,mjs} files including those from node_modules, so any malicious package with a .plugin.js file can execute arbitrary code when installed or required. All projects using this loading behavior are affected, especially those installing untrusted packages. This issue has been fixed in version 0.0.5. To workaround this issue, users can audit and restrict which packages are installed in node_modules.

CVSS 7.6 · Alta · EPSS 0,6% · Corrección disponible

Publicación
Actualización

Pila tecnológica: node

Productos y versiones afectados

  • slyde

    Versiones
    • < 0.0.5: Afectada

    Sin corrección publicada

  • @tygo-van-den-hurk/slyde npm

    Intervalos de versiones afectados
    • SEMVER: < 0.0.5

    Actualiza a 0.0.5

Fuentes originales

Comprueba tu servidor →